Docker Community Forums

Share and learn in the Docker community.

Dockerd hanging at level=info msg="API listen on //./pipe/docker_engine"


(Meyersrl) #1

Ive tried everything I can think of to get the basic docker setup on my windows 2016 image to no avail.

Everything hangs when trying to run the basic hello-world container or if I just run dockerd it gets stuck at this point
level=info msg=“API listen on //./pipe/docker_engine”

Ive turned off Symantec, Windows Defender, Installed Containers, gone through reboots, Im an admin on the machine and nothing.

Literally just trying to get basic DockerEE started and run hello-world

Docker Info

Containers: 2
Running: 0
Paused: 0
Stopped: 2
Images: 1
Server Version: 17.06.2-ee-7
Storage Driver: windowsfilter
Windows:
Logging Driver: json-file
Plugins:
Volume: local
Network: l2bridge l2tunnel nat null overlay transparent
Log: awslogs etwlogs fluentd json-file logentries splunk syslog
Swarm: inactive
Default Isolation: process
Kernel Version: 10.0 14393 (14393.2125.amd64fre.rs1_release.180301-2139)
Operating System: Windows Server 2016 Standard
OSType: windows
Architecture: x86_64
CPUs: 4
Total Memory: 16GiB
Name: rober32894405
ID: EN7S:LHL6:5HM2:52RS:5X2A:ZR2L:KAJT:FRNR:XEWF:SBF2:YLUH:4CXT
Docker Root Dir: C:\ProgramData\docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false

Results of just running dockerd, it never moves past the last step here

time=“2018-03-29T19:55:00.481002600-05:00” level=info msg=“Windows default isolation mode: process”
time=“2018-03-29T19:55:00.482002400-05:00” level=info msg="[graphdriver] using prior storage driver: windowsfilter"
time=“2018-03-29T19:55:00.493002700-05:00” level=info msg=“Graph migration to content-addressability took 0.00 seconds”
time=“2018-03-29T19:55:00.493002700-05:00” level=info msg=“Loading containers: start.”
time=“2018-03-29T19:55:00.504001800-05:00” level=info msg=“Restoring existing overlay networks from HNS into docker”
time=“2018-03-29T19:55:00.619022500-05:00” level=info msg=“Loading containers: done.”
time=“2018-03-29T19:55:00.623023300-05:00” level=info msg=“Daemon has completed initialization”
time=“2018-03-29T19:55:00.623023300-05:00” level=info msg=“Docker daemon” commit=925df35 graphdriver=windowsfilter version=17.06.2-ee-7
time=“2018-03-29T19:55:00.637022700-05:00” level=info msg=“API listen on //./pipe/docker_engine”

Update:
Using dockerd -D gets me past this but I still can’t get hello-world to run. It hangs here now

time=“2018-03-29T20:12:18.213323900-05:00” level=debug msg=“HCSShim::Container::Start id=ba671df21620fa5afb9a982409edd06
94e7e7ea97e84b50c613edfb0581c900f”

One final thought, this is a Virtual Machine, I don’t have Hyper-V enabled as a role and when I tried to enable it said the “The processor does not have the required virtualization capabilities”

Could this be the problem?