Docker Community Forums

Share and learn in the Docker community.

Does the Vulnerability scanning feature work with Alpine distributions or does not?

I’m reading through the docker scan documentation and it says,

The Vulnerability scanning feature doesn’t work with Alpine distributions.

Link: Vulnerability scanning for Docker local images | Docker Documentation

so does it work or not work with Alpine image? if it does, please update the documentation.

You should have quoted the whole section… Allow me to quote it with the context it is embedded in:

Known issues

WSL 2

  • The Vulnerability scanning feature doesn’t work with Alpine distributions.

Ineed this is ambigious. It is unclear if Alpine as the WSL2 distribution is ment (which would make most sense) or images based on Alpine.

Though, since this is not a general issue, it is less likely to be related to images based on Alpine… and Synk (which is used under the hood) supports vulnerability scans on Alpine.