Docker Community Forums

Share and learn in the Docker community.

Don't get any information if scale is unsuccessfull or something went wrong


(Meszarosl) #1

It happened to me when I wanted to scale tutum/hello-world container.
I wanted to scale it to 12 container and 3 was successfull but 9 wasn’t and I didn’t get any information about that I just saw 12 containers on dashboard, but 9 was in created state. So they were “dead”.
Or something similar.


(John) #2

This would be helpful.

I think the issue is with open ports. I tried to scale an nginx container and they got stuck at “started” doing logs in UCP didn’t show anything but going to the host and trying a docker start returns:

Error response from daemon: Cannot start container a1dfaded9491: failed to create endpoint condescending_davinci on network bridge: Bind for 0.0.0.0:30500 failed: port is already allocated

EDIT: Just tried a “restart” in UCP and it did return a similar error: {“data”:“Cannot restart container 41323beeb704362c711af1db212e7b77acbd7ef1e755753bdfbd19899885797c: failed to create endpoint berserk_mietner on network bridge: Bind for 0.0.0.0:30500 failed: port is already allocated\n”,“status”:500,“config”:{“method”:“POST”,“transformRequest”:[null],“transformResponse”:

So it can be seen in UCP without having to go directly to host. Just doesn’t show in “logs” when looking at the container.