Docker Community Forums

Share and learn in the Docker community.

DTR 2.2.3 - /api/v0/openid/callback - 404 page not found

Hi there,

I have just finished installing a small UCP cluster - all based on Docker CS Engine 1.13.1-cs2 on Ubuntu 16.04.2 LTS. My UCP node appears to be working fine, and the two Docker worker nodes also appear fine.

I just ran an install of DTR on the 3rd node - the installation appeared to proceed well, but failed during the last stages:

INFO[0135] Trying to get the kv store connection back after reconfigure INFO[0136] Verifying auth settings... INFO[0136] Waiting for DTR to start... INFO[0141] Waiting for DTR to start... INFO[0146] Waiting for DTR to start... INFO[0151] Waiting for DTR to start... INFO[0156] Waiting for DTR to start... INFO[0161] Waiting for DTR to start... INFO[0166] Waiting for DTR to start... INFO[0171] Waiting for DTR to start... INFO[0176] Waiting for DTR to start... INFO[0181] Waiting for DTR to start... INFO[0186] Waiting for DTR to start... INFO[0191] Waiting for DTR to start... INFO[0196] Waiting for DTR to start... INFO[0201] Waiting for DTR to start... INFO[0206] Waiting for DTR to start... INFO[0211] Waiting for DTR to start... INFO[0216] Waiting for DTR to start... INFO[0221] Waiting for DTR to start... INFO[0226] Waiting for DTR to start... INFO[0231] Waiting for DTR to start... INFO[0236] Waiting for DTR to start... INFO[0241] Waiting for DTR to start... INFO[0246] Waiting for DTR to start... INFO[0251] Waiting for DTR to start... INFO[0256] Waiting for DTR to start... INFO[0261] Waiting for DTR to start... INFO[0266] Waiting for DTR to start... INFO[0271] Waiting for DTR to start... INFO[0276] Waiting for DTR to start... INFO[0281] Waiting for DTR to start... WARN[0286] Couldn't confirm authentication works, but still completing installation: Failed to wait for dtr to come back up: Polling failed with 30 attempts 5s apart: Unexpected status when hitting openid begin path 404 INFO[0287] Installation is complete INFO[0287] Replica ID is set to: f1cd345c5217 INFO[0287] You can use flag '--existing-replica-id f1cd345c5217' when joining other replicas to your Docker Trusted Registry Cluster

If I navigate to the DTR registry in my web browser, it redirects as it attempts to authenticate and ends up failing on the URL:

/api/v0/openid/callback

The page simply says “404 page not found”

Has anyone else seen this issue? Is there anything I can try to debug this?

Many thanks,

James

Do you have the command you used to do the installation? This usually happens when your --dtr-external-url command is set incorrectly.

That’s exactly what it was - thanks for your help!

Could you explain what you did to make it work, I am facing exactly same problem.

Can you post the log output for how it failed? There are a couple of different scenarios that can cause this to happen. Usually it’s the --dtr-external-url setting it set incorrectly, or there are connectivity issues between the hosts (like a firewall).