Docker Community Forums

Share and learn in the Docker community.

DTR backup issue

Hi,

im trying to backup my DTR containers but i get this error :slight_smile:

the command i ran :
[root@node2 tmp]# docker run -i --rm docker/dtr backup --ucp-url https://ucp.docker.ovm --ucp-insecure-tls --ucp-username admin --hub-username $NAME --hub-password$PASSWORD --ucp-password $PASSWORD’ > /tmp/backup.tar.gz

i get this :
INFO[0000] Validating UCP cert
INFO[0000] Connecting to UCP
INFO[0000] UCP cert validation successful
INFO[0000] This cluster contains the replicas: 7a78625fc57f
Choose a replica to back up from [7a78625fc57f]:
FATA[0001] Failed to check equal version: Failed version match. Replica version 2.1.0 doesn’t match bootstrap version 2.1.3.

what to do ?

[quote=“5003152, post:1, topic:26756”]
docker run -i --rm docker/dtr backup --ucp-url https://ucp.docker.ovm --ucp-insecure-tls --ucp-username admin --hub-username $NAME --hub-password$PASSWORD --ucp-password $PASSWORD’ > /tmp/backup.tar.gz[/quote]

Can you try this with docker/dtr:2.1.3? Your latest tag looks like it may be pointing to 2.1.0.

i did it :

docker pull docker/dtr:2.1.3

2.1.3: Pulling from docker/dtr
Digest: sha256:753a687fff0fc1b250a83f841766d4e52254cde4f7afa81cbc5bfc5dcb44a563
Status: Downloaded newer image for docker/dtr:2.1.3

but stil same error

Oh! I totally misread the logs on your first post. Did you try it with docker/dtr:2.1.0? I think you tried it with 2.1.3 in both instances. You should make certain you’re running the same version of the bootstrapper as your installed version.

well i run this :

docker run -i --rm docker/dtr:2.1.0 backup --ucp-url https://ucp.olm --ucp-username admin --ucp-password ‘!$PASS’ --ucp-insecure-tls --existing-replica-id 7a78625fc57f > /tmp/backup.tar

and have still an error :
FATA[0016] Problem running container ‘dtr-phase2’ from image ‘docker/dtr:2.1.0’: Couldn’t create container ‘dtr-phase2’ from image ‘docker/dtr:2.1.0’: Polling failed with 15 attempts 1s apart: Error response from daemon: Unable to find a node that satisfies the following conditions

my containers:
b0c671b97d43 docker/dtr-jobrunner:2.1.0
4dbcecc2ad53 docker/dtr-nginx:2.1.0
2a065e5964c7 docker/dtr-api:2.1.0
5a779266352a docker/dtr-registry:2.1.0

my images:
docker/dtr 2.1.3 5dc6de2da5f5 2 weeks ago 104 MB
docker/dtr latest 5dc6de2da5f5 2 weeks ago 104 MB
docker/dtr-jobrunner 2.1.0 c5f8be7b9bd1 8 weeks ago 142.3 MB
docker/dtr 2.1.0 4aad0b1fec70 8 weeks ago 100.1 MB
docker/dtr-api 2.1.0 8c473763efbf 8 weeks ago 152.4 MB
docker/dtr-registry 2.1.0 11c58c47f366 8 weeks ago 109.4 MB
docker/dtr-rethink 2.1.0 bcb0c597579d 8 weeks ago 103.9 MB
docker/dtr-nginx 2.1.0 fb9da68e9ffc 8 weeks ago 88.88 MB
docker/dtr-notary-server 2.1.0 c63bf199ee10 8 weeks ago 85.74 MB
docker/dtr-notary-signer 2.1.0 aafd8bceea83 8 weeks ago 84.59 MB
docker/dtr 2.0.3 c69bad023d14 5 months ago 51.51 MB
docker/dtr-registry 2.0.3 ed435f6c4ac3 5 months ago 110.6 MB
docker/dtr-rethink 2.0.3 0a914eaac1cb 5 months ago 79.95 MB
docker/dtr-nginx 2.0.3 645bda5cea0f 5 months ago 89.83 MB
docker/dtr-api 2.0.3 f7bce211a3ca 5 months ago 94.6 MB
docker/dtr-etcd v2.2.4 205bc764d14b 12 months ago 28.65 MB

I think what you’re running in to is a problem with UCP scheduling. I’m not sure which version of UCP you’re running, but I believe it’s “Admin Settings -> Scheduler”. There should be a checkbox which either allows/prevents you from running containers on DTR nodes. Change the setting, save and then try re-running the DTR bootstrapper again.