Docker Community Forums

Share and learn in the Docker community.

DTR upgrade from 2.3 to 2.4 throws FATAL

(Martijn Pepping) #1

During the upgrade of DTR 2.3.4 to 2.4.0 the following error is thrown:

FATA[0175] Failed to reconfigure: failed to hub config after reconfigure: Polling failed with 30 attempts 1s apart: Failed to check tls certs in order: Failed to parse CA 
ERRO[0226] Upgrade has failed. Try running it again. 
FATA[0226] Failed to execute phase2: Problem running container 'dtr-phase2' from image 'docker/dtr:2.4.0': non-zero return code returned from docker/dtr:2.4.0 : 1 

The outcome is equal when running the upgrade as:

docker run -it --rm docker/dtr:2.4.0 upgrade --ucp-ca "$(cat ca.pem)"


docker run -it --rm docker/dtr:2.4.0 upgrade --ucp-insecure-tls

We’re using custom CA+certs on both UCP and DTR. Both are valid and confirm with DTR documentation. Has anyone seen the same error when upgrading?

Rgrds, Martijn.

(Patrick Devine) #2

Hey Martijn,

Do you have more of the logs? How did the one with the --ucp-insecure-tls option fail?

(Martijn Pepping) #3


Both failed with exact the same error-message. Was able to resolve the issue by running the following prior to running the upgrade:

docker run -it --rm docker/dtr reconfigure --dtr-external-url ${FQDN} \
--ucp-insecure-tls --ucp-url https://${UCP-FQDN}/

Rgrds, Martijn.