Docker Community Forums

Share and learn in the Docker community.

Error: Build in 'master' (90c89f58)


(Semantida) #1

Build in ‘master’ (90c89f58)

What is this error? Appeared today, yesterday still everything worked.


Issue with Automated Build - ERROR: Error when trying to create deploy key
(Andreamercieca) #2

I had the same problem and had been trying to find out what was going on for 24 hours because the error is cryptic and the logs are practically non existent along with the staff. I however had set up the automated build to send me an email upon failure and I was getting “Error while creating deploy keys”.

Are you using a private repository like I am with BitBucket? What I had to do was go to the BitBucket repository in question and get the SSH access key for Docker Build and paste it in an environment variable for the automated build. The key for the environment variable is ‘SSH_PRIVATE’

Let me know if it works for you.


(Semantida) #3

It is very interesting, but why until May 25, all the work itself.


(Willseward) #4

I’m seeing the same issues. I think BitBucket is having some problems ATM, but that could be unrelated.


(phil) #5

Have you managed with this? I’m still having this problem and I’m not sure on who’s end the problem is sitting - super frustrating


(Semantida) #6

It is necessary to delete keys every time on bitbucket before build start.


(phil) #7

Yeah I also saw that is a small work around. But that is ridiculous we can’t do it for every build - that defeats the purpose of “automated” builds. Do you think this is a issue on bitbucket or dockers side?


(Semantida) #8

The most intern, it all started on May 25, when new rules for processing data entered. On the side of the docker errors occur with different statuses.


(Theotech) #9

I followed the directions here: https://docs.docker.com/docker-cloud/builds/automated-build/#build-repositories-with-linked-private-submodules and it solved my problem.

I just generated a new keypair, set the private key in the SSH_PRIVATE environment variable and added the public key as an access key for my bitbucket repository and my builds are working now.