Error Installing On Premise BitWarden with Docker - Server 2016

Hello all. I am rather new to Docker and am having a tough time getting self-hosted BitWarden to install in Docker running on Server 2016. My Docker and Docker Compose information are:

Docker version 17.10.0-ee-preview-3, build 1649af8
docker-compose version 1.25.4, build 8d51620a

The issue is when I run the install scripts in PowerShell for self-hosted BitWarden. The install will begin and I will input some information (the domain name) and get past the part where it asks if I want to generate a free SSL. I answer this and PowerShell begins pulling from bitwarden/setup, but then I get the following error:

C:\Program Files\Docker\docker.exe: failed to register layer: failed to start service utility VM (applydiff 0b6a9f83ec55ba27faef5491affc6afd26e18a93a91ef13744
2fe7e5d8d7e099): container 0b6a9f83ec55ba27faef5491affc6afd26e18a93a91ef137442fe7e5d8d7e099_svm encountered an error during CreateContainer: failure in a Wind
ows system call: The data is invalid. (0xd) extra info: {“SystemType”:“container”,“Name”:"0b6a9f83ec55ba27faef5491affc6afd26e18a93a91ef137442fe7e5d8d7e099_svm
",“Layers”:null,“HvPartition”:true,“HvRuntime”:{“ImagePath”:“C:\Program Files\Linux Containers”,“LinuxInitrdFile”:“initrd.img”,“LinuxKernelFile”:“bootx64.ef

Has anyone dealt with this issue before? I have been searching for answers and tried multiple tips, but to no avail.

Any help on the matter is greatly appreciated.