Docker Community Forums

Share and learn in the Docker community.

Error response from daemon: Get https://registry-1.docker.io/v2/: remote error: tls: handshake failure


(Kleisetamatia) #1

Expected behavior

docker container run hello-world:nanoserver
output:

Hello from Docker!
This message shows that your installation appears to be working correctly.

To generate this message, Docker took the following steps:

  1. The Docker client contacted the Docker daemon.
  2. The Docker daemon pulled the “hello-world” image from the Docker Hub.
    (windows-amd64, nanoserver-1803)
  3. The Docker daemon created a new container from that image which runs the
    executable that produces the output you are currently reading.
  4. The Docker daemon streamed that output to the Docker client, which sent it
    to your terminal.

To try something more ambitious, you can run a Windows Server container with:
PS C:> docker run -it microsoft/windowsservercore powershell

Actual behavior

PS C:\Users…> docker container run hello-world:nanoserver
Unable to find image ‘hello-world:nanoserver’ locally
C:\Program Files\Docker\docker.exe: Error response from daemon: Get “https://registry-1.docker.io/v2/”: remote error: tls: handshake failure.
See ‘C:\Program Files\Docker\docker.exe run --help’.

Information

Windows Version
systeminfo:

  • OS Name: Microsoft Windows Server 2016 Standard
  • OS Version: 10.0.14393 N/A Build 14393
  • Hotfix(s): 3 Hotfix(s) Installed.
    [01]: KB4049065
    [02]: KB4132216
    [03]: KB4338822
    docker info:
  • Server Version: 17.06.2-ee-16
  • Kernel Version: 10.0 14393 (14393.2395.amd64fre.rs1_release_inmarket.180714-1932)
  • Operating System: Windows Server 2016 Standard
  • OSType: windows
  • Architecture: x86_64

Event logs:

Firewall is disabled and I don’t use any proxy.

Steps to reproduce the behavior

Install-Module DockerMsftProvider -Force
Install-Package Docker -ProviderName DockerMsftProvider -Force

(Install-WindowsFeature Containers).RestartNeeded

Restart-Computer

docker container run hello-world:nanoserver


(Trevorbhc) #2

Did you ever get this fixed? Having same issue. Thanks


(Kleisetamatia) #3

Hi,

I am not 100% that this is the fix but when I properly setup the hyper-v networking, which it is created by default when you install docker, it worked. Check your networking that you still have access to the outside of your network through docker.