Docker Community Forums

Share and learn in the Docker community.

Error: The requested resource is in use. (Only when using --memory)

OS: Windows 10 Enterprise 2004 (19041.329)
App Version: Docker Desktop (42716), Engine: 19.03.5

I have been using Docker for Windows Desktop on a Windows 10 desktop for the past 6 months. I create containers using the --memory argument usually 4g to give them enough memory to run build tasks.

I am no longer able to start a new container using the --memory argument. No matter what value I try I end up with the following error:

c:\program files\docker\docker\resources\bin\docker.exe: Error response from daemon: hcsshim::CreateComputeSystem f38e68ee157b81bc09e6cf91eebadf2f6b47a9e44f22692326385f55d8b0ccf5: The requested resource is in use.

As soon as I try to start the container without the --memory argument, it works just fine.

Some additional background:
The first time this happened, I was running a container, and I it appeared my computer had froze (I doubt it had anything to do with docker). So I restarted my computer and later noticed the container had not restarted. When I went to start it, that was the first time I got the error message above. So I removed the container and recreated it from the same image I had been using and have not been able to get it started using the --memory flag since.

I have 32GB of ram and have maybe 50% in use. I tried rebooting my computer again and starting the container using --memory as soon as it rebooted, but still no luck.

After some more testing I found that I get the same error if I try to use the base image my container image is built from (.Net Framework SDK on Server Core). If I try a container image that I built from Nano Server then I can use --memory.

I ended up using the Factory Reset option in Docker Desktop. After pulling fresh images, I am able to use the --memory flag again.