Docker Community Forums

Share and learn in the Docker community.

Error when running docker with init_networkdriver


(Badroum) #1

Hi,

When I run a docker .I have this error:

2015/03/10 10:59:41 docker daemon: 1.0.1 990021a; execdriver: native; graphdriver:
[a3f43dae] +job serveapi(unix:///var/run/docker.sock)
[a3f43dae] +job initserver()
[a3f43dae.initserver()] Creating server
2015/03/10 10:59:41 Listening for HTTP on unix (/var/run/docker.sock)
[a3f43dae] +job init_networkdriver()
[a3f43dae.init_networkdriver()] creating new bridge for docker0
package not installed
[a3f43dae] -job init_networkdriver() = ERR (1)
package not installed
[a3f43dae] -job initserver() = ERR (1)
2015/03/10 10:59:41 package not installed

I’m on a ubuntu VM 3.13.0-042stab094.8
Can you help me?


(Sam Saffron) #2

Are you sure you have all the pre-reqs it is complaining about a missing package also docker daemon version seems rather old.


(Bersaelor) #3

I got the exact same error when I had the exact same docker version.

Did a clean virgin Ubuntu 14.04 install on a new server, followed the Ubuntu-Tutorial from you guys:
https://docs.docker.com/installation/ubuntulinux/#ubuntu-trusty-1404-lts-64-bit

Then I updated to the latest version from your repo “https://get.docker.com/ubuntu docker main”.
Result is still the similar:

root@v31636:~# docker -v
Docker version 1.5.0, build a8a31ef
root@v31636:~# docker -d
INFO[0000] +job serveapi(unix:///var/run/docker.sock)   
INFO[0000] Listening for HTTP on unix (/var/run/docker.sock) 
INFO[0000] +job init_networkdriver()                    
package not installed
INFO[0000] -job init_networkdriver() = ERR (1)          
FATA[0000] package not installed

Maybe this is also relevant:

root@v31636:/# cat /proc/cgroups 
#subsys_name	hierarchy	num_cgroups	enabled