Exposing custom (tpc) ports for URBackup


I am experiencing a problem with URBackup service whereby custom ports do not work the same way as the default port.
when I expose port 55414:55414 (on the router as well) then I can get external access to the web interface. When I use a custom port eg. 90:55414 for the container and configure my router 55414:90 I am unable to access the webinterface. I have tried adding /tcp tag to the exposed ports(55413-55415), but this did not resolve the issue.
Ultimately I intend to run multiple URBackup services and have a load balancer direct traffic to the appropriate service, but I cannot proceed until I have resolved the issue with the custom ports.

Please point out my ignorance so I can improve upon it, I don’t know what I’m missing
Assistance will be dearly appreciated

Thank you

Well, first, please, red the descriptions of the categories you hoose for your topics. Tips & HowTos is for sharing tips, not asking for it which is basically what everyone does in almost every category. I moved it to general discussion as I don’t know much about your environment.

expose of forward? Please, share how you create the container and how you define the port for it. Expose is just metadata, not port forward, but I guess you indeed forwarded the port.

How exactly? What is the error message in the browser? What happens?

Hi Rimelek, thank you for taking the time to respond, and moving my topic to the correct category.

This is the configuration that gives me problems:

version: ‘3’
image: uroni/urbackup-server:latest
container_name: urbackup
restart: unless-stopped
- 91-93:55413-55415

and on the router I forward external port 55414 to the server’s port 92

In Firefox I get the error “The connection was reset” when I connect from an external network. The page fails to load in its entirety on the local network, but works fine through cloudflared tunnel

What’s your router? A DSL router with port forwarding? Your provider has not blocked the external port?

Why go from 55xxx to 9x and back? Port numbers below 1024 are considered privileged and sometimes require special rights.

Thanks for sharing the ports with range, I didn’t know that exists, learning every day :slightly_smiling_face: (doc)

Hi BluePuma, Thank you for taking a moment to engage.

ISP does not block the ports, because when I forward 55413-55415 on the WAN side to 55413-55415 on internal, then the connection works, the clients can connect to the server and I get full service from an external network.

The purpose of going from default to custom and back is to test the functionality. I would like to host multiple instances of the service from one docker server, I cannot expose the same port to multiple services and thus each instance needs its own set of custom ports. Once I get this problem resolved, the default ports will point to my load balancer which will then direct traffic to the appropriate custom ports (and service) based on ACL.
I just now tried custom ports 2013-2015:55413-55415 with the same results, so I suspect the special rights you mention do not have an impact on the current issue - thanks for pointing it out