Docker Community Forums

Share and learn in the Docker community.

Fail in enable multi-host networking for docker engine - etcd cluster is unavailable or misconfigured


(Clarence Ho) #1

I have problem when trying to enable multi-host networking by following the UCP documentation site.

My setup is below:

UCP Controller:

  1. IP Address: 202.181.203.18
  2. Domain name: ucp.skywidesoft.com (I entered this as the SAN during installation)
  3. SSL: I am using my own cert which is a wildcard certificate (please see attached image on the alternative name of the cert)
  4. Network interface: em2
  5. OS: CentOS 7.1 (kernel 4.3.0)

In the docker.service file, I added the following options:
–cluster-advertise em2:12376 --cluster-store etcd://ucp.skywidesoft.com:12379 --cluster-store-opt kv.cacertfile=/var/lib/docker/discovery_certs/ca.pem --cluster-store-opt kv.certfile=/var/lib/docker/discovery_certs/cert.pem --cluster-store-opt kv.keyfile=/var/lib/docker/discovery_certs/key.pem

Two issues:

  1. For the option “–cluster-advertise”, I found that I can only start docker engine when using the network interface name (i.e. em2), docker engine fail to start when I use either the IP (202.181.203.18) or SAN (ucp.skywidesoft.com)
  2. For the option “–cluster-store”, I found that no matter I use the IP address or SAN, I still found errors in the docker service log indicates that there is error in connecting to etcd

level=error msg="Registering as “202.181.203.18:12376” in discovery failed: client: etcd cluster is unavailable o
950968618+08:00" level=error msg=“discovery error: Unexpected watch error”

I also suspect that since I am using my own cert, I should use my own cert for docker engine to use. So I also tried to copy my certificates to the above folder and restart docker. However, the same error happens.

I check the log of the controller container and find that it’s working properly, don’t know why can’t connect from docker engine.

Kindly advice


Error when configuring Docker daemon for UCP multi-host networking