Docker Community Forums

Share and learn in the Docker community.

Fail to create network - failed to parse pool request


(Clarence Ho) #1

I tried to create a network in Docker UCP but there is error.

In the UCP panel, network, I create the network and pass in the following 2 fields:

  • name: skywidesoft-net
  • driver: overlay

I also attached the image here.

However, I got the following error:
Error response from daemon: 500 Internal Server Error: failed to parse pool request for address space “GlobalDefault” pool “” subpool “”: cannot find address space GlobalDefault (most likely the backing datastore is not configured)

The same error appears in both the UCP panel and CLI.

In CLI, I issue the following command:
docker network create --driver overlay skywidesoft-net

Kindly advice
Clarence


UCP and overlay networks (Internal Server Error)
(Anoop) #2

Hi,

The networking features in UCP rely on the multi-host networking options passed to the docker daemon.

From your previous posts, I gather that you’re using CentOS. So, after you install UCP (which you already have), you need to modify the docker startup options (You can use this link) to use the following:

--cluster-advertise CURRENT_HOST_PUBLIC_IP_OR_DNS:12376
--cluster-store etcd://CONTROLLER_PUBLIC_IP_OR_DNS:12379
--cluster-store-opt kv.cacertfile=/var/lib/docker/discovery_certs/ca.pem
--cluster-store-opt kv.certfile=/var/lib/docker/discovery_certs/cert.pem
--cluster-store-opt kv.keyfile=/var/lib/docker/discovery_certs/key.pem

Restart the docker daemon and then retry the overlay network creation.


(Clarence Ho) #3

I just notice this in the installation guide about this.

Will follow the instruction and try again.

Thanks a lot
Clarence