Docker Community Forums

Share and learn in the Docker community.

Failed to install Docker Desktop on Windows 10 Pro. How can I resolve this error?

Hello,

I don’t have much experience with Docker and have been trying to install it many times but I always get the same error message. I have tried multiple versions, but it is always the same error. Could someone help me fix it.

I am using Windows 10 Pro and the Docker Desktop installer I have is version 3.2.2.

The error message I get is:

Failed to register product: The COM class generator for the component with CLSID {1ECCA34C-E88A-44E3-8D6A-8921BDE9E452} could not be retrieved due to the following error: 80070422 The service cannot be started, because it is disabled or because it does not have enabled devices associated with it. (Exception from HRESULT: 0x80070422).
at CommunityInstaller.InstallWorkflow. d__29.MoveNext ()
— End of stack trace from previous location where exception occurred —
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw ()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (Task task)
at CommunityInstaller.InstallWorkflow. d__23.MoveNext ()

I have tried many solutions that I have found on the internet but at the moment none have worked for me.

Thank you very much in advance for your help.