Failed to register layer: ApplyLayer exit status 1 stdout: stderr: lchown /etc/OpenCL/vendors/intel.icd: disk quota exceeded

$ docker pull plexinc/pms-docker
Using default tag: latest
latest: Pulling from plexinc/pms-docker
d7bfe07ed847: Pull complete 
f0e332c09d6b: Extracting [==================================================>]  129.6MB/129.6MB
99fb2508798a: Download complete 
e298ea7970f4: Download complete 
failed to register layer: ApplyLayer exit status 1 stdout:  stderr: lchown /etc/OpenCL/vendors/intel.icd: disk quota exceeded
$ docker version
 Version:           20.10.14-qnap2
 API version:       1.41
 Go version:        go1.16.15
 Git commit:        be617d7
 Built:             Fri Apr  8 10:06:21 2022
 OS/Arch:           linux/amd64
 Context:           default
 Experimental:      true

Server: Docker Engine - Community
  Version:          20.10.14-qnap2
  API version:      1.41 (minimum version 1.12)
  Go version:       go1.16.15
  Git commit:       3bb6db2
  Built:            Fri Apr  8 10:09:48 2022
  OS/Arch:          linux/amd64
  Experimental:     false
  Version:          v1.5.11
  GitCommit:        3df54a852345ae127d1fa3092b95168e4a88e2f8
  Version:          1.0.3
  GitCommit:        v1.0.3-0-gf46b6ba2
  Version:          0.19.0
  GitCommit:        de40ad0
$ docker info
 Context:    default
 Debug Mode: false

 Containers: 3
  Running: 3
  Paused: 0
  Stopped: 0
 Images: 8
 Server Version: 20.10.14-qnap2
 Storage Driver: overlay2
  Backing Filesystem: extfs
  Supports d_type: true
  Native Overlay Diff: false
  userxattr: false
 Logging Driver: json-file
 Cgroup Driver: cgroupfs
 Cgroup Version: 1
  Volume: local
  Network: bridge host ipvlan macvlan null overlay qnet
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: io.containerd.runc.v2 io.containerd.runtime.v1.linux kata-runtime runc
 Default Runtime: runc
 Init Binary: docker-init
 containerd version: 3df54a852345ae127d1fa3092b95168e4a88e2f8
 runc version: v1.0.3-0-gf46b6ba2
 init version: de40ad0
 Security Options:
   Profile: default
 Kernel Version: 5.10.60-qnap
 Operating System: QTS 5.0.0 (20220531)
 OSType: linux
 Architecture: x86_64
 CPUs: 4
 Total Memory: 7.622GiB
 Name: NAS4F4EED
 Docker Root Dir: /share/CACHEDEV1_DATA/Container/container-station-data/lib/docker
 Debug Mode: true
  File Descriptors: 63
  Goroutines: 65
  System Time: 2022-07-08T09:08:52.211804721+08:00
  EventsListeners: 1
 Experimental: false
 Insecure Registries:
 Live Restore Enabled: false
 Product License: Community Engine
 Default Address Pools:
   Base:, Size: 22

Looks like a quota is exceeded, which could be a filesystem quota, an inode exhaustion, kernel parameters with too low max limits set or something entirely else. The error is not specific enought to realy see what the root cause for this error message is.

I can imagine that a temporary mitigation could be to purge all unused images with docker image prune --all or if you feel bold all stopped containers, not used networks/images and the build cache: docker system prune --all. Though, this will not fix what causes the issue in first place. Maybee there is a quota on /share/CACHEDEV1_DATA/?

You might want to ask the qnap community about this, as it is high likely you are not the only one beeing affected by this.

1 Like

Can you share the output of df --inodes? It allows us to see if inodes of your filesystem are exhausted.