Docker Community Forums

Share and learn in the Docker community.

Failed to start docker since the 1.11.1-beta14 update


(Kannan Manickam) #1

Expected behavior

Docker should start successfully

Actual behavior

It keeps hanging at “Docker is starting”

Information

Diagnostic ID: 555845F9-ED92-4EB3-8CF2-3E8138E0F0B3
Details:

Docker for Mac: version: v1.11.1-beta14.5.m
OS X: version 10.11.5 (build: 15F34)
logs: /tmp/20160606-165413.tar.gz
failure: /Users/kmanickam/Library/Containers/com.docker.docker/Data/com.docker.driver.amd64-linux/console-ring does not exist
[ERROR]  docker-cli
         docker ps failed
[OK]     app
[OK]     menubar
[OK]     virtualization
[OK]     system
[OK]     osxfs
[OK]     db
[OK]     slirp
[OK]     moby-console
[OK]     logs
[OK]     vmnetd
[OK]     env
[ERROR]  moby
         /Users/kmanickam/Library/Containers/com.docker.docker/Data/com.docker.driver.amd64-linux/console-ring does not exist
[OK]     driver.amd64-linux

Steps to reproduce the behavior

  1. Update from 1.11.1-beta13 to 1.11.1-beta14

(Yvann Boucher) #2

I have exactly the same problem, same logs.


(Eadz) #3

I have the same issue, same error message.

Because this is a BETA, can Beta users please have a way to downgrade when things break? Is there any way to downgrade?


(Matej Nemček) #4

yes. I found on disk Version 1.11.1-beta12 (build: 7528) if someone want.
beta-14 doesnt starts for me


(Eadz) #5

Thanks for the offer Matej, however it would be great to have an official link for security reasons


(Crashdump) #6

A workaround is to delete Docker’s Library folder:
$ rm -rf ~/Library/Containers/com.docker.docker

Be careful as this will also totally WIPE all your local containers/images.


(Eadz) #7

@crashdump thanks, that actually worked!

I had installed docker on a fresh OSX, and it had never booted up before. Now it’s running! :grin:


(Crashdump) #8

A simple way to reproduce the error is to disable native/port-forwarding:
$ pinata set native/port-forwarding false


(Rick Peters) #9

If i use pinata set network nat (my default) docker for mac stops working. It keeps starting?
Performing pinata set network hostnet ‘solved’ the problem…


(Lucas Chaufournier) #10

I am having the same issue with the same logs. Brand new installation on a new OS install with the latest update(v1.11.1-beta14.5.m). Diagnostic ID:AB8906D5-A1C6-453E-84DB-933A713D76B5


(Sheldon Bachstein) #11

Same issue here. I just get “Docker is Starting” ad infinitum if the pinata network is set to NAT (which is what I need). Dead in the water with Docker for Mac until this is resolved. Diagnostic ID: E455F35C-EC11-41E3-B42E-3B558164B50C


(Luca D.) #12

Exact same issue.
Report ID: F7FCBD58-5850-4B94-ABBD-37BEF6762F46


(Mike Ebinum) #13

Yep I’m having the same problems as well.