Docker Community Forums

Share and learn in the Docker community.

Getting MineOS-Node working in a docker


(Leodavinci) #1

So, I am trying to create a docker for MineOS-Node. I want to use this on an unRaid server. I have been using hernandito’s docker (which I’m pretty sure is a fork of Yujiod’s, i tried to link but I’m limited to two.) in successfully for about 4 months or so. The problem i have with it is that it uses the python version of MineOS and I would like to upgrade to the Node version to get the newer features. I tried to just tweak his to get it to upgrade, but the problem is I cant get it to compile. I tried just going into the docker after it starts and upgrading the WebUI that way, but it just makes my web UI stop responding.

So, what I have done is try to create my own. I finally have a dockerfile that will compile on it’s own, but when I run it, it just starts mineOS and quits and I can’t access the webUI.

Here is my dockerfile. Any help or suggestions would be greatly appreciated. I’m guessing I am going to have to add some more scripts of some sort, but am lost at this point.

FROM ubuntu:trusty
MAINTAINER erg.cgs@gmail.com

#These commands are taken straight from http://minecraft.codeemo.com/mineoswiki/index.php?title=MineOS-node_(apt-get)

RUN apt-get -y install curl
RUN curl -L https://deb.nodesource.com/setup_5.x | bash - 
RUN apt-get update
RUN apt-get -y install nodejshttps://github.com/yujiod/docker-mineos
#RUN apt-get -y install npm
RUN apt-get -y install git 
RUN apt-get -y install rdiff-backup 
RUN apt-get -y install screen 
RUN apt-get -y install build-essential 
RUN apt-get -y install openjdk-7-jre-headless
RUN apt-get -y install rsync

RUN mkdir -p /usr/games
WORKDIR /usr/games
RUN git clone https://github.com/hexparrot/mineos-node.git minecraft
WORKDIR /usr/games/minecraft
RUN git config core.filemode false
RUN chmod +x service.js 
RUN chmod +x mineos_console.js 
RUN chmod +x generate-sslcert.sh 
RUN chmod +x webui.js
RUN npm install
RUN ln -s /usr/games/minecraft/mineos_console.js /usr/local/bin/mineos 
RUN cp mineos.conf /etc/mineos.conf
RUN cp /usr/games/minecraft/init/upstart_conf /etc/init/mineos.conf
RUN ./generate-sslcert.sh


# Cleaning
RUN apt-get clean

VOLUME /var/games/minecraft
WORKDIR /usr/games/minecraft
EXPOSE 22 8443 2556

ENTRYPOINT "start mineos"