Docker Community Forums

Share and learn in the Docker community.

Gitlab LFS dial tco error

I have a gitlab docker running on my CentOS machine working pretty well. Recently, I decide to play with LFS , so I turned on lfs_enabled in gitlab.rb, and make sure LFS is on in my gitlab project setting. However, I kept getting error while push my master to remote.

LFS: Put "http://1c2b94a621ae/tmp_user/test.git/gitlab-lfs/objects/4ec5a16b43e48447a619488b6c857396bc09fe3c6eaafee5493ada39286b775f/287377686": dial tcp: lookup 1c2b94a621ae: no such host

error: failed to push some refs to 'http://192.168.1.15:8087/tmp_user/test.git

Search online for a while, still couldn’t figure it out. Why did LFS try to connect using 1c2b94a621ae, which is my gitlab container id, instead of host ip? What cause this error? How do I solve this problem?

Any ref link/read will be appreciated.


CentOS 7.9.2009
Docker 20.10.1
docker-compose version 1.27.4

docker-compose.yml

version: "3.8"

services:
    gitlab-ce:
        container_name: gitlab-ce
        image: gitlab/gitlab-ce:latest
        ports:
            - '1443:443'
            - '8087:80'
            - '2287:22'
        volumes:
            - /srv/gitlab-ce/config:/etc/gitlab
            - /srv/gitlab-ce/logs:/var/log/gitlab
            - /srv/gitlab-ce/data:/var/opt/gitlab
            - /srv/gitlab-ce/lfs-objects:/mnt/storage/lfs-objects
        deploy:
            resources:
                limits:
                    cpus: '1.0'
                    memory: 16G
        restart: unless-stopped

Go and most other tools that handle proxies support multiple environment variables to control the proxies used. For HTTP, this is the http_proxy environment variable, and for HTTPS, both http_proxy and https_proxy are consulted.

It looks like you may have one or both of those set in your environment; unsetting them may help you connect directly to the server.

1 Like

Thanks for the reply, I tried set HTTP_PORXY="", also tried to set NO_PROXY but still no luck. After some try and error. it turns out that I just need to set add in gitlab.rb

external_url "http://x.x.x.x"