Docker Community Forums

Share and learn in the Docker community.

How can I set a static ip so the ip's can stop changing

Could someone please let me know what is wrong with my docker-compose file. I tried to settup static ips and they still are changing.

version: "2.1"
networks:
  vlan:
    driver: macvlan
    driver_opts:
      parent: eth0
    ipam:
      config:
        - subnet: "192.168.0.0/24"
          ip_range: "192.168.0.64/26"
          gateway: "192.168.0.1"
services:
  plex:
    image: ghcr.io/linuxserver/plex
    container_name: plex

    environment:
      - PUID=1000
      - PGID=1000
      - VERSION=docker
      - PLEX_CLAIM= #optional
    volumes:
      - S:/DockerENT/Config/plex:/config
      - S:/DockerENT/TV:/tv
      - S:/DockerENT/Movies:/movies
      - S:/DockerENT/Music:/music
    ports:
      - 32400:32400
      - 8888:8888
      - 58351:58351 #SSH
    restart: unless-stopped
    networks:
      vlan:
        ipv4_address: 192.168.0.7


  headphones:
    image: ghcr.io/linuxserver/headphones
    container_name: headphones

    environment:
      - PUID=1000
      - PGID=1000
      - TZ=Europe/London
    volumes:
      - S:/DockerENT/Config/Headphones:/config
      - S:/DockerENT/Downloads:/downloads
      - S:/DockerENT/Music:/music
    ports:
      - 8181:8181
      - 58352:58352 #SSH
    restart: unless-stopped
    networks:
      vlan:
        ipv4_address: 192.168.0.3
  jackett:
    image: ghcr.io/linuxserver/jackett
    container_name: jackett

    environment:
      - PUID=1000
      - PGID=1000
      - TZ=Europe/London
      - AUTO_UPDATE=true #optional
      - RUN_OPTS=<run options here> #optional
    volumes:
      - S:/DockerENT/Config/Jackett:/config
      - S:/DockerENT/Downloads:/downloads
    ports:
      - 9117:9117
      - 58353:58353 #SSH
    restart: unless-stopped
    networks:
      vlan:
        ipv4_address: 192.168.0.2
  deluge:
    image: ghcr.io/linuxserver/deluge
    container_name: deluge

    environment:
      - PUID=1000
      - PGID=1000
      - TZ=Europe/London
      - DELUGE_LOGLEVEL=error #optional
    volumes:
      - S:/DockerENT/Config/Deluge:/config
      - S:/DockerENT/Downloads:/downloads
    ports:
      - 58846:58846
      - 58946:58946
      - 8112:8112
      - 58354:58354 #SSH
    restart: unless-stopped
    networks:
      vlan:
        ipv4_address: 192.168.0.4
  couchpotato:
    image: ghcr.io/linuxserver/couchpotato
    container_name: couchpotato

    environment:
      - PUID=1000
      - PGID=1000
      - TZ=Europe/London
    volumes:
      - S:/DockerENT/Config/couchpotato:/config
      - S:/DockerENT/Downloads:/downloads
      - S:/DockerENT/Movies:/movies
    ports:
      - 5050:5050
      - 58355:58355 #SSH
    restart: unless-stopped
    networks:
      vlan:
        ipv4_address: 192.168.0.6
  sonarr:
    image: ghcr.io/linuxserver/sonarr
    container_name: sonarr

    environment:
      - PUID=1000
      - PGID=1000
      - TZ=Europe/London
    volumes:
      - S:/DockerENT/Config/Sonarr:/config
      - S:/DockerENT/TV:/mnt/tv #optional
      - S:/DockerENT/Downloads:/downloads #optional
    ports:
      - 8989:8989
      - 58356:58356 #SSH
    restart: unless-stopped
    networks:
      vlan:
        ipv4_address: 192.168.0.5