Docker Community Forums

Share and learn in the Docker community.

How do I increase the size of Local Volumes?

The following configuration of the mariadb database is available docker-compose.xml

mysql:
    image: mariadb:10.3.9
    healthcheck:
      test: "/usr/bin/mysql --user=root --password=pass --execute \"SHOW DATABASES;\""
      interval: 2s
      timeout: 20s
      retries: 10
    ports:
      - "3306:3306"
    volumes:
      - ./db:/var/lib/mysql
    environment:
      MYSQL_ROOT_PASSWORD: pass
      MYSQL_DATABASE: sitemanager
      MYSQL_USER: app
      MYSQL_PASSWORD: pass
    command: ['--innodb-use-native-aio=0', '--innodb-flush-method=fsync', '--character-set-server=utf8', '--collation-server=utf8_unicode_ci', '--skip-character-set-client-handshake', '--sql-mode=']

Everything worked normally, but at one point it stopped. Can’t start the container with the database, because the database crashes with errors.

2020-05-13 13:19:05 0 [ERROR] InnoDB: preallocating 50331648 bytes for file ./ib_logfile101 failed with error 38
2020-05-13 13:19:05 0 [ERROR] InnoDB: Cannot set log file ./ib_logfile101 size to 50331648 bytes
TYPE                TOTAL               ACTIVE              SIZE                RECLAIMABLE
Images              30                  2                   4.864GB             3.785GB (77%)
Containers          2                   1                   4.482kB             0B (0%)
Local Volumes       20                  0                   707.6MB             707.6MB (100%)
Build Cache         0                   0                   0B                  0B

Local Volume = 100% I think that all the trouble is in it. How can I increase the volume of LocalVolumes , or maybe I need to throw the database into the container in some other way?

Docker settings https://i.imgur.com/ocFEcFX.pn