Docker Community Forums

Share and learn in the Docker community.

How to enable icc for docker_gwbridge

Hi,

I am running docker service via overlay network. when I look into the container, I found there are two ips:

21: eth0@if22: <BROADCAST,MULTICAST,UP,LOWER_UP,M-DOWN> mtu 1450 qdisc noqueue state UP
link/ether 02:42:0a:00:00:07 brd ff:ff:ff:ff:ff:ff
inet 10.0.0.7/24 scope global eth0
valid_lft forever preferred_lft forever
inet 10.0.0.6/32 scope global eth0
valid_lft forever preferred_lft forever
23: eth1@if24: <BROADCAST,MULTICAST,UP,LOWER_UP,M-DOWN> mtu 1500 qdisc noqueue state UP
link/ether 02:42:ac:12:00:03 brd ff:ff:ff:ff:ff:ff
inet 172.18.0.3/16 scope global eth1

the 10.0.0.x is the overlay ip and the other one 172.18.0.3 i found is attached to the docker_gwbridge on the host machine:

9: docker_gwbridge: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
link/ether 02:42:a8:dc:8a:38 brd ff:ff:ff:ff:ff:ff
inet 172.18.0.1/16 scope global docker_gwbridge

and using docker network I also found the icc is disabled for this network:

    "Options": {
        "com.docker.network.bridge.enable_icc": "false",
        "com.docker.network.bridge.enable_ip_masquerade": "true",
        "com.docker.network.bridge.name": "docker_gwbridge"
    }

Here comes my problem:

I have another container which is running under docker0 bridge:

4: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default
link/ether 02:42:8d:ec:39:7a brd ff:ff:ff:ff:ff:ff
inet 172.17.0.1/16 scope global docker0

my target is to access the docker_gwbridge ip 172.18.0.3 from within this docker0 container. as you can guess, I can’t make it. I am wondering if that icc:false option is blamed for this? and how to make it work?