Docker Community Forums

Share and learn in the Docker community.

How to make 2 GB memory available to mssql-server-linux image?


(Shueybubbles) #1

I installed the EE preview on a 1709 server core VM:
Server Version: 17.10.0-ee-preview-3
Storage Driver: windowsfilter (windows) lcow (linux)
LCOW is enabled.
I am unable to run the mssql-server-linux image because it needs 2GB of RAM:
PS C:\smotest> docker run -e “ACCEPT_EULA=Y” -e “SA_PASSWORD=mypassword101” -h sqlserver --name sqlserver -p:1433 --isolation hyperv -m 4GB --rm microsoft/mssql-server-linux
sqlservr: This program requires a machine with at least 2000 megabytes of memory.
If I run the base ubuntu image, top reports less than 1 GB total mem. How do I force the container to be big enough for SQL to run?


(Archimedes Trajano) #2

In the HyperV settings you can increase the ram of Moby.


(Shueybubbles) #3

I don’t see any VMs running in hyperv.
EG here’s the dotnet image running in docker, get-vm returns no VMs. I ran hyperv manager from another machine, too, since the EE beta is running on server core, and it didn’t show any VMs either.

PS C:\scripts> docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
40ed14e821f5 microsoft/dotnet “bash” 12 seconds ago Up 6 seconds hungry_franklin
PS C:\scripts> get-vm
PS C:\scripts> get-vm -Verbose
PS C:\scripts> get-vm Moby
get-vm : Hyper-V was unable to find a virtual machine with name “Moby”.
At line:1 char:1

  • get-vm Moby
  •   + CategoryInfo          : InvalidArgument: (Moby:String) [Get-VM], VirtualizationException
      + FullyQualifiedErrorId : InvalidParameter,Microsoft.HyperV.PowerShell.Commands.GetVM

(Petservas) #4

LCOW not using Hyper-V virtual mashine


(Petservas) #5

-m 4g - set windows memory and not set linux memory inside windows. this is bag.


(Shueybubbles) #6

turns out to be a known limitation: https://github.com/Microsoft/opengcs/issues/145