Docker Community Forums

Share and learn in the Docker community.

Ibm-messaging/mq-docker won't run on mac os x [SOLVED]

build
docker

(Lockpicker) #1

Resources and material on running mq on mac os x seems to be very limited. I’ve tried a few different images and seem to come up with the same problem. Any help would be much appreciated.

When starting the docker mq image i get the following error


Name: WebSphere MQ
Version: 8.0.0.4
Level: p800-004-151022.DE
BuildType: IKAP - (Production)
Platform: WebSphere MQ for Linux (x86-64 platform)
Mode: 64-bit
O/S: Linux 4.1.19-boot2docker
InstName: Installation1
InstDesc:
Primary: Yes
InstPath: /opt/mqm
DataPath: /var/mqm
MaxCmdLevel: 802
LicenseType: Developer

mqconfig: V3.7 analyzing Ubuntu 14.04.4 LTS settings for WebSphere MQ V8.0

System V Semaphores
semmsl (sem:1) 32000 semaphores IBM>=32 PASS
semmns (sem:2) 0 of 1024000000 semaphores (0%) IBM>=4096 PASS
semopm (sem:3) 500 operations IBM>=32 PASS
semmni (sem:4) 0 of 32000 sets (0%) IBM>=128 PASS

System V Shared Memory
shmmax 18446744073692774399 bytes IBM>=268435456 PASS
shmmni 0 of 4096 sets (0%) IBM>=4096 PASS
shmall 0 of 18446744073692774399 pages (0%) IBM>=2097152 PASS

System Settings
file-max 224 of 201494 files (0%) IBM>=524288 FAIL

Current User Limits (root)
nofile (-Hn) 1048576 files IBM>=10240 PASS
nofile (-Sn) 1048576 files IBM>=10240 PASS

ERROR: mqconfig returned a non-zero return code


(Lockpicker) #2

Just when you post :slight_smile:
Found some instructions here

https://github.com/ibm-messaging/mq-docker/issues/13

Will try and report back.


(Lockpicker) #3

OK. So we resolved one issue and straight into another one.

Now I’m getting an error message about log not available and am just as stuck. Again, any help would be much appreciated.


Name: WebSphere MQ
Version: 8.0.0.4
Level: p800-004-151022.DE
BuildType: IKAP - (Production)
Platform: WebSphere MQ for Linux (x86-64 platform)
Mode: 64-bit
O/S: Linux 4.1.19-boot2docker
InstName: Installation1
InstDesc:
Primary: Yes
InstPath: /opt/mqm
DataPath: /var/mqm
MaxCmdLevel: 802
LicenseType: Developer

mqconfig: V3.7 analyzing Ubuntu 14.04.4 LTS settings for WebSphere MQ V8.0

System V Semaphores
semmsl (sem:1) 32000 semaphores IBM>=32 PASS
semmns (sem:2) 0 of 1024000000 semaphores (0%) IBM>=4096 PASS
semopm (sem:3) 500 operations IBM>=32 PASS
semmni (sem:4) 0 of 32000 sets (0%) IBM>=128 PASS

System V Shared Memory
shmmax 18446744073692774399 bytes IBM>=268435456 PASS
shmmni 0 of 4096 sets (0%) IBM>=4096 PASS
shmall 0 of 18446744073692774399 pages (0%) IBM>=2097152 PASS

System Settings
file-max 320 of 524288 files (0%) IBM>=524288 PASS

Current User Limits (root)
nofile (-Hn) 1048576 files IBM>=10240 PASS
nofile (-Sn) 1048576 files IBM>=10240 PASS

WebSphere MQ queue manager ‘QM1’ starting.
The queue manager is associated with installation ‘Installation1’.
AMQ7017: Log not available.

I should also mention that I tried to follow the instruction on the mq-docker github page:

AMQ7017: Log not available
If you see this message in the container logs, it means that the
directory being used for the container’s volume doesn’t use a filesystem
supported by IBM MQ. This often happens when using Docker Toolbox or
boot2docker, which use tmpfs for the /var directory. To solve this, you need to make sure the container’s /var/mqm volume is put on a supported filesystem. For example, with Docker Toolbox try using a directory under /mnt/sda1. You can list filesystem types using the command df -T

My interpretation was:

docker run --env LICENSE=accept --env MQ_QMGR_NAME=QM1 --volume /mnt/sda1:/var/mqm --publish 1414:1414 mq

But that returned
AMQ7047: An unexpected error was encountered by a command. Reason code is 0.


(Lockpicker) #4

Ok finally after some trial and error, this is solved.

for everyone else’s benefit follow this:

ssh into your docker-machine : docker-machine ssh
create a new folder under /mnt/sda1: sudo mkdir /mnt/sda1/var/log

and run the machine like so:

docker run --env LICENSE=accept --env MQ_QMGR_NAME=QM1 --volume /mnt/sda1/var/log:/var/mqm --publish 1414:1414 mq