Docker Community Forums

Share and learn in the Docker community.

Installation Docker EE Stable 19.03.1-3 on SLES 15 fails

Hi all,

our Installation of docker-ee-19.03.1-3.x86_64.rpm from SLES Stable Repo fails with an unresolvable dependency:

sudo zypper in ./docker-ee-19.03.0-3.x86_64.rpm
Loading repository data…
Reading installed packages…
Resolving package dependencies…

Problem: nothing provides libseccomp >= 2.3 needed by docker-ee-3:19.03.0-3.x86_64
Solution 1: do not install docker-ee-3:19.03.0-3.x86_64
Solution 2: break docker-ee-3:19.03.0-3.x86_64 by ignoring some of its dependencies

When searching for libseccomp it shows that libseccomp2 is already installed, but that doesn’t seem to satisfy the dependency, both in a 2.3.x version and in 2.4.1-70-1 and with additional installation of devel-packages. On only the source is available.

I don’t think building source packages is part of installing a stable release of Docker for a certified OS, so, what am i missing?


We wouldn’t ordinarily expect that type of error. Have you had a look at our installation instructions for EE on SLES?

Also, if you’re a Docker Enterprise customer with a paid, active subscription, if you have issues, I encourage you or your team to file an issue with Docker Technical Support (via and they’d be happy to assist you and your team.

Hi, thanks for your quick reply. We have installed previous EE versions during trial on SLES 12. I see that the current SLES installation docs you pointed to are quoting SLES 12 as a prerequisite though the existence of a SLES 15 stable Docker EE release suggests otherwise, as well as later info in the Installation docs, for example:
SLES_VERSION is 15 or 12.3 when setting the repo for Docker EE. We will address this with Docker Technical Support.

Thanks !

Seems that the problem exists only with the 19.03.X-Versions, the 18.09.8-3 installed without Problems.