Docker Community Forums

Share and learn in the Docker community.

Installation fails on Path /var/lib/kubelet is mounted on /var but it is not a shared mount. Please refer to https://www.docker.com/ddc-42 for more information


(Rick Peters) #1

Just tried installing UCP3 beta 2 and failed on this message. Looked into the KB article and tried following actions:

  • made the used mount shareable per instruction
  • made the used mount recursive shareable
  • added MountFlags to systemd docker.service file (both = ‘empty’ and =shared) (based on issues found on internet with rancher)
  • Tried putting docker in experimental mode

Nothing helps, we still get this issue. We have no idea how to proceed anymore.

Environment info:

Linux  3.10.0-693.11.1.el7.x86_64 #1 SMP Fri Oct 27 05:39:05 EDT 2017 x86_64 x86_64 x86_64 GNU/Linux

Docker version:
Client:
 Version:      17.06.2-ee-6
 API version:  1.30
 Go version:   go1.8.3
 Git commit:   e75fdb8
 Built:        Mon Nov 27 22:43:47 2017
 OS/Arch:      linux/amd64

Server:
 Version:      17.06.2-ee-6
 API version:  1.30 (minimum version 1.12)
 Go version:   go1.8.3
 Git commit:   e75fdb8
 Built:        Mon Nov 27 22:45:04 2017
 OS/Arch:      linux/amd64
 Experimental: true

Docker info:
Containers: 1
 Running: 1
 Paused: 0
 Stopped: 0
Images: 2
Server Version: 17.06.2-ee-6
Storage Driver: devicemapper
 Pool Name: vgdocker-dockerpool
 Pool Blocksize: 65.54kB
 Base Device Size: 10.74GB
 Backing Filesystem: xfs
 Data file: 
 Metadata file: 
 Data Space Used: 94.96MB
 Data Space Total: 10.52GB
 Data Space Available: 10.42GB
 Metadata Space Used: 200.7kB
 Metadata Space Total: 109.1MB
 Metadata Space Available: 108.9MB
 Thin Pool Minimum Free Space: 1.051GB
 Udev Sync Supported: true
 Deferred Removal Enabled: true
 Deferred Deletion Enabled: true
 Deferred Deleted Device Count: 0
 Library Version: 1.02.140-RHEL7 (2017-05-03)
Logging Driver: journald
Cgroup Driver: cgroupfs
Plugins: 
 Volume: local
 Network: bridge host ipvlan macvlan null overlay
 Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 6e23458c129b551d5c9871e5174f6b1b7f6d1170
runc version: 810190ceaa507aa2727d7ae6f4790c76ec150bd2
init version: 949e6fa
Security Options:
 seccomp
  Profile: default
Kernel Version: 3.10.0-693.11.1.el7.x86_64
Operating System: Red Hat Enterprise Linux
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 3.702GiB
Name: sou684.so.kadaster.nl
ID: LP2E:YDME:4LVZ:GRRB:5G77:RGCP:GPT6:SDXK:Y6N7:WOQX:XTOV:HDMB
Docker Root Dir: /var/appdata/docker
Debug Mode (client): false
Debug Mode (server): false
Http Proxy: http://www-proxy.cs.kadaster.nl:8082
Https Proxy: http://www-proxy.cs.kadaster.nl:8082
No Proxy: localhost,127.0.0.1,kadaster.nl
Registry: https://index.docker.io/v1/
Labels:
 com.plp.container=jap-ucp-mt
 com.plp.release=yoda_3_1706
 com.plp.datacenter=amsterdam
Experimental: true
Insecure Registries:
 127.0.0.0/8
Live Restore Enabled: false

(Vivek Saraswat) #2

Hi rickpeters,

Apologies for the delay–engineering team is investigating this right now. Will get back to you soon on this.