Docker Community Forums

Share and learn in the Docker community.

Installation issues on Ubuntu 14.04 on EC2

docker

(Vishalmodak) #1

I tried to install ucp on Ubuntu 14.04 on an EC2 instance. I get the following error

root@ip-10-215-66-208:/home/ubuntu# docker run --rm -it -v /var/run/docker.sock:/var/run/docker.sock --name ucp dockerorca/ucp install -i
Unable to find image ‘dockerorca/ucp:latest’ locally
latest: Pulling from dockerorca/ucp
f08f7de64c4e: Pull complete
87a6bbaf1f90: Pull complete
Digest: sha256:ed7e723c1a42d0b09b3b7e2743dd61543140363c6aa18c5ea9856fca823f3be8
Status: Downloaded newer image for dockerorca/ucp:latest
INFO[0000] Verifying your system is compatible with UCP
Please choose your initial Orca admin password:
Confirm your initial password:
INFO[0007] Pulling required images
Please enter your Docker Hub username: vishalmodak
Please enter your Docker Hub password:
Please enter your Docker Hub e-mail address: vishalmodak@gmail.com
INFO[0019] Pulling required images
ERRO[0023] We were unable to pull one or more required images. Please set REGISTRY_USERNAME, REGISTRY_PASSWORD, and REGISTRY_EMAIL environment variables for your Docker Hub account on this container with -e flags to run.
FATA[0023] Error: image dockerorca/ucp-proxy:latest not found

I tried to pass the USERNAME, PASSWORD & EMAIL using -e flags…However, that also didnt work for me.
I tried deleted /etc/docker/key.json (suggested in another topic)…didnt help…


(Vivek Saraswat) #2

Hi Vishal check to see if you are a part of the “dockerorca” organization in your hub account. If not, please PM me the name you signed up with for the beta, your email, and your docker hub account name.