Docker Community Forums

Share and learn in the Docker community.

Installing UCP on RHEL7.3 getting blocked port


(Jcchris2) #1

Installing UCP on RHEL7.3 and port 179 says its blocked but the firewall is not turned on, we have a proxy setting but have tried a -e no-proxy switch and set up the no proxy in the HTTP and HTTPS proxy files, we cannot figure out what would be blocking it only shows its listening when ucp-port-check-179 container runs as part of the install. Is this a bug with RHEL7.3 or is there some way to unblock port 179 again the firewall isn’t active.

sudo systemctl status firewalld
● firewalld.service
Loaded: masked (/dev/null; bad)
Active: inactive (dead)

FATA[0033] the following required ports are blocked on your host: 179. Check your firewall settings


(Jcchris2) #2

UCP version is 3.0.2 have also tried 3.0.0 get the same error


(Manglu) #3

I don’t believe it is a bug. Some changes require a OS restart.

Disable the firewall and restart the OS to see if you any difference.


(Jcchris2) #4

The 179 port is below 4000 so it was blocked by default, the firewall was disabled but the port needed to be added to the IPTABLES file. Added this entry and reloaded the IPTABLES and the install was successful. The xxx.-xxx. is the IP address range.

-A INPUT -p tcp -m multiport --dports 179 -m iprange --src-range xxx.xxx.xxx.xxx-xxx.xxx.xxx.xxx -j ACCEPT

xxx.xxx

-A INPUT -p tcp -m multiport --dports 179 -m iprange --src-range xxx.xxx.xxx.xxx-xxx.xxx.xxx.xxx -j ACCEPT

172.16

-A INPUT -p tcp -m multiport --dports 179 -m iprange --src-range xxx.xxx.xxx.xxx-xxx.xxx.xxx.xxx -j ACCEPT

xxx

-A INPUT -p tcp -m multiport --dports 179 -m iprange --src-range xxx.xxx.xxx.xxx-xxx.xxx.xxx.xxx -j ACCEPT