Docker Community Forums

Share and learn in the Docker community.

Invalid Licence when using Trial Licence from store


(Hleclerc) #1

OS Version/build :
Linux ucp-controller 4.4.0-47-generic #68-Ubuntu SMP Wed Oct 26 19:39:52 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

App version : ucp:3.0.0-beta2

Steps to reproduce

Using doccumentation https://goto.docker.com/rs/929-FJL-178/images/Docker-EE-Beta-Exercises.pdf

Install :

docker container run --rm -it --name ucp -v /var/run/docker.sock:/var/run/docker.sock docker/ucp:3.0.0-beta2 install --host-address 10.100.2.6 --controller-port 8443 -i

UI OK with 2 options :

  • Upload License
  • Get free trial or license

If I use “Get free trial or license” and use the downloaded licence from trial : i get error invalid licence

Where do we get trial 2.0 licences ?


(Netunes) #2

Same problem for our install


(Ollypom) #3

Sorry, the Licenses on the “Free trial” only work on GA products. You can request a beta license from https://beta.docker.com/ and hopefully you should receive an Email.


(Netunes) #4

i received the email for the beta programn, downloaded the .lic files and the uploaded on ucp page but it says is invalid.


(Vivek Saraswat) #5

netunes a couple of questions:

  • which docker/ucp tag are you running for the install?
  • When you go to your Store profile --> My Content, under “Docker Enterprise Edition” does the license say “Advanced - Beta | 100 Nodes”?

(Netunes) #6

it says: Advanced - Beta | 100 Linux (x86-64) Nodes, 100 Windows (x86-64) Nodes
Started January 22, 2018 | Ends April 22, 2018
i just downloaded the license .lic file and tried to upload on UCP page at first logon, result is invalid license.


(Netunes) #7

If you mean the version we have 2.2.4


(Vivek Saraswat) #8

Ah I think this is the problem. You cannot use the beta license with 2.2.4 which is a production version. As per the Beta Exercise Guide, you need to use the UCP beta version (docker/ucp:3.0.0-beta2). Try that and see if it works!


(Netunes) #9

Thanks, it worked.
just one another question, DTR still says Unlicensed copy. Please register your license on the Settings page.


(Satyaki1008) #10

yes same problem is happening with me,ucp works fine but DTR says “unlicensed copy”,while in the settings page of DTR,the license is showing the same one that I uploaded while logging into UCP.
I installed DTR by following the email instructions on the worker node managed by UCP.Any solution?