Docker Community Forums

Share and learn in the Docker community.

"Invalid signal: SIGWINCH" when building linux container on Windows Server 2019 with Docker Enterprise

I am attempting to build docker containers on a server running Windows Server 2019 with Docker Enterprise. I am using docker-compose. The server seems to be properly configured, as I have successfully run a bare-bones Linux container after configuring the server per the instructions found here:

The docker environment I am attempting to create works fine on my Windows 10 laptop running Docker Desktop.

The error occurs when it setting the WORKDIR (specified in my Dockerfile)

Step 5/6 : WORKDIR /srv/app
ERROR: Service ‘app’ failed to build: Invalid signal: SIGWINCH

Here is my complete Dockerfile:

FROM php:7.4-apache

COPY . /srv/app
COPY .docker/vhost.conf /etc/apache2/sites-available/000-default.conf
COPY .docker/uploads.ini /usr/local/etc/php/conf.d/uploads.ini

WORKDIR /srv/app

RUN apt-get update \
    && apt-get install -y \
        libicu-dev \
        libfreetype6-dev \
        libjpeg62-turbo-dev \
        libpng-dev \
        imagemagick \
        libmagickwand-dev \
    && docker-php-ext-configure gd --with-freetype --with-jpeg \
    && docker-php-ext-install \
        -j$(nproc) gd \
        intl mysqli pdo pdo_mysql \
    && pecl install imagick \
    && docker-php-ext-enable imagick \
    && chown -R www-data:www-data /srv/app \
    && a2enmod rewrite \
    && sed -i '/disable ghostscript format types/,+6d' /etc/ImageMagick-6/policy.xml

Any ideas what the issue might be? This is a small internal application. Is one possible solution to maybe run Docker Desktop instead of Docker Enterprise on Windows Server 2019? Thank you so much for any assistance you can provide.