Docker Community Forums

Share and learn in the Docker community.

Issue installing UCP on Ubuntu 16.04?

Set the proper repo to get the latest docker engine (1.12.3 build 6b644ec). When I try to install the UCP trial, I get my build it too old.

Your engine version 1.12.3 OSS is too old. UCP requires at least version 1.12.1 CS or 1.13.0 OSS

Any suggestions on what I am doing incorrectly?

~# docker run --rm -it --name ucp \

-v /var/run/docker.sock:/var/run/docker.sock
docker/ucp install
–host-address 10.53.182.0
–interactive
INFO[0000] Verifying your system is compatible with UCP
FATA[0000] Your engine version 1.12.3 OSS is too old. UCP requires at least version 1.12.1 CS or 1.13.0 OSS.

You need yo install 1.12.1 CS(Commercial Support) version

In case Ubuntu:
apt-get install docker-engine=1.12.1~cs1-0~trusty

Check what according to your Linux distro

Thanks, yes tried to finish out my topic last week but the forum locked me out from replying.

Thanks,
Leo