Docker Community Forums

Share and learn in the Docker community.

Issues with moving containers/images to a new box


(Ajzimme) #1

Hey guys, I’ve tried to move a couple interconnected containers I have here on an Ubuntu 16.04 box to a Redhat 7 box. From what I read the host OS shouldn’t matter that much. Either way,

The run cmds are:

docker run --name tcexam --restart=always -v /media/docker/tcexam/www:/var/www/html -p 8080:80 --link sql:mysql -d richarvey/nginx-php-fpm

docker run --name sql --restart=always -v /media/docker/mysql/data:/var/lib/mysql -e MYSQL_ROOT_PASSWORD=**** -e MYSQL_USER=*** -e MYSQL_DATABASE=survey -p 3306:3306 -d mysql

So the steps I’ve taken so far are,

First I just ran the same commands on the new box, and the problem was the site wouldn’t come up.

We do use Caddy, and I copied the configuration over and it works fine for another site.

The containers run fine, but the site doesn’t come up. I’m not sure what’s going on.

After just running the commands, I figured, maybe it’s the image. So I exported the images, and imported them. Then ran the commands. Same deal.

After this, I tried exporting the containers themselves, also, with the exported images (should be the same exact thing right!?) and got the same thing. Site doesn’t load.

Also, keep in mind, I rsynced over the referenced directories in the run commands.