Issues with starting daemon after install. Debian 13

Alright, here’s my docker info and my Journalctl.

Mar 24 08:27:39 debian systemd[1]: Starting docker.service - Docker Application Container Engine...
░░ Subject: A start job for unit docker.service has begun execution
░░ Defined-By: systemd
░░ Support: https://www.debian.org/support
░░ 
░░ A start job for unit docker.service has begun execution.
░░ 
░░ The job identifier is 108578.
Mar 24 08:27:39 debian dockerd[3230623]: time="2026-03-24T08:27:39.317482212-05:00" level=info msg="Starting up"
Mar 24 08:27:39 debian dockerd[3230623]: time="2026-03-24T08:27:39.318553207-05:00" level=info msg="OTEL tracing is not configured, using no-op tracer provider"
Mar 24 08:27:39 debian dockerd[3230623]: time="2026-03-24T08:27:39.318818366-05:00" level=info msg="CDI directory does not exist, skipping" dir=/etc/cdi
Mar 24 08:27:39 debian dockerd[3230623]: time="2026-03-24T08:27:39.318829480-05:00" level=info msg="CDI directory does not exist, skipping" dir=/var/run/cdi
Mar 24 08:27:39 debian dockerd[3230623]: time="2026-03-24T08:27:39.327338835-05:00" level=info msg="Creating a containerd client" address=/run/containerd/containerd.sock timeout=1m0s
Mar 24 08:27:39 debian dockerd[3230623]: time="2026-03-24T08:27:39.334497712-05:00" level=info msg="Loading containers: start."
Mar 24 08:27:39 debian dockerd[3230623]: time="2026-03-24T08:27:39.334530614-05:00" level=info msg="NRI is disabled"
Mar 24 08:27:39 debian dockerd[3230623]: time="2026-03-24T08:27:39.334537964-05:00" level=info msg="Starting daemon with containerd snapshotter integration enabled"
Mar 24 08:27:39 debian dockerd[3230623]: time="2026-03-24T08:27:39.337267248-05:00" level=info msg="Restoring containers: start."
Mar 24 08:27:39 debian dockerd[3230623]: time="2026-03-24T08:27:39.375662384-05:00" level=info msg="Deleting nftables IPv4 rules" error="exit status 1" output="Error: Could not process rule: No such file or directory\ndelete table ip docker-bridges"
Mar 24 08:27:39 debian dockerd[3230623]: time="2026-03-24T08:27:39.411618784-05:00" level=info msg="Deleting nftables IPv6 rules" error="exit status 1" output="Error: Could not process rule: No such file or directory\ndelete table ip6 docker-bridges"
Mar 24 08:27:40 debian dockerd[3230623]: time="2026-03-24T08:27:40.414510829-05:00" level=info msg="stopping event stream following graceful shutdown" error="<nil>" module=libcontainerd namespace=moby
Mar 24 08:27:40 debian dockerd[3230623]: time="2026-03-24T08:27:40.415080612-05:00" level=info msg="Daemon shutdown complete" error="failed to start daemon: Error initializing network controller: error creating default \"bridge\" network: all predefined address pools have been fully subnetted"
Mar 24 08:27:40 debian dockerd[3230623]: failed to start daemon: Error initializing network controller: error creating default "bridge" network: all predefined address pools have been fully subnetted
Mar 24 08:27:40 debian dockerd[3230623]: time="2026-03-24T08:27:40.415111730-05:00" level=info msg="stopping event stream following graceful shutdown" error="context canceled" module=libcontainerd namespace=plugins.moby
Mar 24 08:27:40 debian systemd[1]: docker.service: Main process exited, code=exited, status=1/FAILURE
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support: https://www.debian.org/support
░░ 
░░ An ExecStart= process belonging to unit docker.service has exited.
░░ 
░░ The process' exit code is 'exited' and its exit status is 1.
Mar 24 08:27:40 debian systemd[1]: docker.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://www.debian.org/support
░░ 
░░ The unit docker.service has entered the 'failed' state with result 'exit-code'.
Mar 24 08:27:40 debian systemd[1]: Failed to start docker.service - Docker Application Container Engine.
░░ Subject: A start job for unit docker.service has failed
░░ Defined-By: systemd
░░ Support: https://www.debian.org/support
░░ 
░░ A start job for unit docker.service has finished with a failure.
░░ 
░░ The job identifier is 108578 and the job result is failed.
ramen@debian:~$ docker info
Client: Docker Engine - Community
 Version:    29.3.0
 Context:    default
 Debug Mode: false
 Plugins:
  buildx: Docker Buildx (Docker Inc.)
    Version:  v0.31.1
    Path:     /usr/libexec/docker/cli-plugins/docker-buildx
  compose: Docker Compose (Docker Inc.)
    Version:  v5.1.1
    Path:     /usr/libexec/docker/cli-plugins/docker-compose

Server:
permission denied while trying to connect to the docker API at unix:///var/run/docker.sock

If you need anything else, I’ll be glad to help. I’m not too sure what’s going on.

(Edit: I forgot to use sudo on the journalctl command, my apologies.)