Docker Community Forums

Share and learn in the Docker community.

Kitematic Mac download corrupt


(Sebastian Wegert) #1

Expected behavior

I’m able to install and start kitematic

Actual behavior

OS X tells me the application is corrupt and suggests to move it to the trashcan

Information

OS X: version 10.11.3 (build: 15D21)
Docker.app: version v1.11.0-beta7
Running diagnostic tests:
[OK] docker-cli
[OK] Moby booted
[OK] driver.amd64-linux
[OK] vmnetd
[OK] osxfs
[OK] db
[OK] slirp
[OK] menubar
[OK] environment
[OK] Docker
[OK] VT-x
Docker logs are being collected into /tmp/20160415-172936.tar.gz
Most specific failure is: No error was detected

Additional information:

  • Docker Toolbox is still installed but not started
  • DOCKER ENV vars are not set using the default shell
  • OS X language is german
  • Docker4Mac is up and running

Steps to reproduce the behavior

  1. click on the docker icon in the task bar
  2. click on “Dashboard…”
  3. In the following dialog that tells you the native ui is not ready yet, click the “Download Kitematic” button
  4. Open Finder and open the download location
  5. Extract the “Kitematic-Mac.zip” file
  6. Double-click the extracted “Kitematic (Beta).app”

This is really low prio and might be off topic but maybe anybody has the same issue…


(Bitdump7) #2

Same issue today, Apr. 20th.


(Cmelion) #3

Same issue today, Apr. 22nd.


(Jason Kane) #4

workaround:

system preferences -> security & privacy
Choose the “General” tab
Click the lock in the lower left corner to unlock
set “Allow apps download from:” to "Anywhere"
Run kitematic

You can (and probably should) restore the security setting after you’ve run it. You shouldn’t have to do that every time, just the first time.


(Albertux) #6

works for me that workaround


(Sebastian Wegert) #7

the workaround works for me too


(Matn) #8

Same issue. (Old MacOS version: 10.10.5, Docker version: 1.11.1-beta12 (build: 7528)

Workaround worked fine.


(Greenkiwi) #9

This seems to be that the app isn’t signed correctly. The two work arounds, here and in https://github.com/docker/kitematic/issues/1637 seem to make this work.