Docker Community Forums

Share and learn in the Docker community.

Kube system pods not visible after editing!

Hi All
I’m using Kubernetes with Windows Docker Desktop and I noticed that when I edit the pod YAML in /etc/kubernetes/manifests it creates the pods and they are working fine. However I can’t see them when I run kubectl get pods -n kube-system. At the time of posting this I’m using the latest version of both docker (v20.10.2) and kubernetes (1.20.2).

If I run docker container ls | grep kube-system or docker ps | grep kube-system I can see the containers.
But none of the below works:
winpty docker exec -it <container-id> //bin//sh
winpty docker exec -it <container-id> //bin//bash
winpty docker exec -it <container-id> /bin/sh
winpty docker exec -it <container-id> /bin/bash
docker exec -it <container-id> //bin//sh
docker exec -it <container-id> //bin//bash
docker exec -it <container-id> /bin/sh
docker exec -it <container-id> /bin/bash

They all give this ERROR message.
OCI runtime exec failed: exec failed: container_linux.go:370: starting container process caused: exec: "sh": executable file not found in $PATH: unknown

I thought that maybe the new docker images for the kube control plane components didnt have a bash or sh installed. But I can’t see why they would remove that. Anyway I used to be able to view and access the pods in kube-system namespace but now I cant after editing.