Linux_Mint_una - localhost

I started my learning of docker 1 week ago so i’m new to this ^^.

it seems that i can curl my localhost but not access to it on a browser.

ti try to connect using “http://localhost:5000/” or “”, “”, but no better results.
I install docker on my linux mint una machine by the way.
I need help on this please, do i need to install apache or something else ?

It doesn’t realy make sense that it’s not working. You publish the container port 5000 to all ipv4 and ipv6 ips on your host. It should actualy work with all available ips of your host on port 5000 - including

Since mint is a fork of ubuntu, is it safe to assume that you installed the offical docker-ce package for ubuntu from docker’s repositores? Only if you installed the official package from docker’s repositores, you can expect vanila docker behavior! If you installed the os package or snap package, then you might experience differences and should ask in the maintainers forums for assistence, as their user base will know where this forked package differes from vanila docker.

Thank you for answering.
I’ve install this “docker-desktop-4.9.0-amd64.deb” downloaded here “Install Docker Desktop on Linux | Docker Documentation”, following the doc’s instruction.
Can you give me a link for the maintainers forums please ?

Thank you a lot !

If you use Docker desktop for Ubuntu, then you are already in the correct forum.

My last response about the behavior was regarding docker-ce. Docker Desktop uses a vm that encapsulates the docker engine to provide a shared experience with all other Docker Desktop variants.

I don’t use Docker Desktop for Ubuntu. So someone probably has to pitch in.

I just noticed that the error page is generated by squid. Which means your browser is configured to use a http_proxy and/or https_proxy.

This way the requests are delegated to the http(s)_proxy, which of course tries to reach on the host that runs the squid proxy. You need to add to the “no proxy” list, so the browser knows to bypass the proxy for requests to that ip.

Note: this problem is not related to docker.

I just figured it out… i was connected to a vpn and forgot about it -_-’
sorry for inconvenience :man_facepalming:

don’t worry. things happen. But you still will want to configure the no_proxy setting to make sure you don’t get suprised should you ever be logged in into vpn.

Sure, can I have a doc link maybe where i can learn more about and how to put this in place please ?
just to be sure i’m well understand, it’s a setting that will allow me to connect even if i’m already connected by vpn ?
Thanks again !

Like I wrote: this is not a docker problem.

If you would have installed a nginx or apache2 server on your host and tried to access it, you would have got the same error message. You might want to ask the admins in your company about it. They should know what applies for employe equipment.

ok, thank you again.