Mac download loses .dmg suffix when using Firefox >=102

Hi

Apologies if this is not the best place to report this, I’ve searched and not found a better one.

When using Firefox 102.0.1, or Firefox Developer Edition 103.0b3, downloading Docker Desktop for Mac from either www docker com / get-started, or docs docker com /desktop/install/mac-install/ (URLs spaced out to avoid stupid post limit), the file is downloaded without its .dmg suffix, making it unusable as is.

It works correctly in Firefox 101.0.1. It also works correctly in Chrome and Safari.
I tried a completely fresh profile in each version of Firefox and had the same result.

So this seems like a Firefox bug right? But:

The download link from hub.docker.com works correctly in all Firefox versions.

And I have not been able to find any other site whose dmg downloads are being stripped of their suffix in the later Firefoxen. I’ve only found this problem with Docker dot com.

So it appears to be something specific to those download links.
They both point to
desktop docker com /mac/main/amd64/Docker.dmg?utm_source=docker&utm_medium=webreferral&utm_campaign=docs-driven-download-mac-amd64
Whereas the one on hub.docker.com points to
desktop docker com /mac/main/amd64/Docker.dmg
In other words, the only apparent difference is the utm_* query args.
I can’t fathom why that would affect the download filename, but apparently it does.