Docker Community Forums

Share and learn in the Docker community.

Manifest for ruby:2.5.1 not found

dockerhub

(Jacobevelyn) #1

I’m a relative Docker beginner and I’m sure this is going to be a silly question, but I’m trying to figure out why this is happening:

$ docker pull ruby:2.5.1
Error response from daemon: manifest for ruby:2.5.1 not found

when the Hub says that 2.5.1 should be available (unless I’m reading that wrong?).

I’ve tried restarting docker and Docker for Mac but no luck. For the record, docker pull ruby:2.5.0 and docker pull ruby:2.5 both work but show me the same hash, implying that ruby:2.5 is pulling 2.5.0 and not the later 2.5.1. Is there something I need to do to update the listing I’m pulling from? Do I need to wait for this new version to propagate somehow?


(Don McCullough) #2

docker pull ruby:2.5.1
works perfectly for me.

2.5.1: Pulling from library/ruby
c73ab1c6897b: Pull complete
1ab373b3deae: Extracting [==================================================>] 11.11MB/11.11MB
b542772b4177: Download complete
57c8de432dbe: Download complete
1785850988c5: Downloading [======================> ] 95.63MB/213.2MB
953e617a9c21: Download complete
09400a4d0988: Download complete
0775b59c37c3: Download complete


(Don McCullough) #3

One thought is list current images do you possibly have an image that somehow is not fully deleted?
‘docker images’ will give you the list of currently downloaded. I have one image that failed to download that showed in images yet terminal had crashed during download and it never finished

I did a ‘Docker rmi ImageID’ and then was able to download it again.


(Jacobevelyn) #4

Huh, so now all of a sudden docker pull ruby:2.5.1 is working for me, even though I’m positive that exact command is what I ran an hour earlier and it failed. (@dairlab I’d already checked and it wasn’t in docker images, but thanks for the suggestion!) I wonder if it just takes a while for new releases (this was released about 24 hours ago) to get propagated through Docker’s data centers? Either that or there was some bug with this that Docker fixed in the past hour or so.

In any event, it looks like my problem has been solved! Thanks!