Docker Community Forums

Share and learn in the Docker community.

More installation woes


(Cameronp) #1

** DISCLAIMER ** I have only just jumped on the docker bandwagon 2 weeks ago, so I am very fresh and am probably missing something fundamental here.

I haven’t been able to get it to install after about 5 attempts on centos 7.1
It keeps complaining about ports being in use randomly - 443 was a problem 2376 etc

however this isn’t the case (ports not in use)

[root@docker1 gitlab]# docker run --rm -it -v /var/run/docker.sock:/var/run/docker.sock --name orca-bootstrap dockerorca/orca-bootstrap install -i --fresh-install
INFO[0000] Verifying your system is compatible with Orca
Please choose your initial Orca admin password:
Confirm your initial password:
INFO[0007] All required images are already available
We detected the following hostnames/IP addresses for this system [docker1.cla.local 127.0.0.1 172.17.0.1 10.3.0.42]

You may enter additional aliases (SANs) now or press enter to proceed with the above list.
Additional aliases:
INFO[0021] Installing Orca with host address 10.3.0.42
INFO[0003] Removing old Orca containers
FATA[0034] The following required ports are already in use on your host - [12380].
[root@docker1 gitlab]# netstat --listen
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:ssh 0.0.0.0:* LISTEN
tcp 0 0 localhost:smtp 0.0.0.0:* LISTEN
tcp6 0 0 [::]:ssh [::]:* LISTEN
tcp6 0 0 localhost:smtp [::]:* LISTEN


(Banjot) #2

do you have other containers running on your host? Can you list the output from a “docker ps” command?


(Cameronp) #3

Yeah I didn’t have anything else running - since it was a fresh centos 7 minimal install, the issue was that ip6 was enabled. So I’ve disabled that and got a little bit further, but now the orca containers cant communicate.

[root@docker1 ~]# docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
[root@docker1 ~]# docker run --rm -it -v /var/run/docker.sock:/var/run/docker.sock --name orca-bootstrap dockerorca/orca-bootstrap install -i --fresh-install
INFO[0000] Verifying your system is compatible with Orca
Please choose your initial Orca admin password:
Confirm your initial password:
INFO[0004] All required images are already available
We detected the following hostnames/IP addresses for this system [docker1.cla.local 127.0.0.1 172.17.0.1 10.3.0.42]

You may enter additional aliases (SANs) now or press enter to proceed with the above list.
Additional aliases:
INFO[0256] Installing Orca with host address 10.3.0.42
INFO[0022] Generating Swarm Root CA
INFO[0052] Generating Orca Root CA
INFO[0081] Deploying Orca Containers
ERRO[0142] We were unable to communicate with proxy we just started at address 10.3.0.42. If this address is incorrect, re-run the install using the ‘–host-address’ option. Run “docker logs orca-proxy” for more details from the proxy
FATA[0142] Unable to connect to system
[root@docker1 ~]# docker logs orca-proxy
Listening on 2376
Using TLS
[root@docker1 ~]# docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
783a6a11fdf4 dockerorca/orca-proxy:latest “/bin/run” 4 minutes ago Up 4 minutes 0.0.0.0:12376->2376/tcp orca-proxy
4e81fbcc1914 dockerorca/orca-etcd:2.2.0 “/bin/etcd --data-dir” 4 minutes ago Up 4 minutes 4001/tcp, 7001/tcp, 0.0.0.0:12379->2379/tcp, 0.0.0.0:12380->2380/tcp orca-kv

note that 10.3.0.42 is the correct ip of the lan network.

Thanks


(Cameronp) #4

wee… got it to install…
not sure how, randomly opened up ports on the firewall, after initial ones didn’t seem to work.

it would fail on install multiple times with this sort of stuff
FATA[0064] 500 Internal Server Error: Cannot start container 9c813a451e547048906 c4da94e382859e0f7ccf0865c7940b69ff62e21792e3d: [8] System error: write /sys/fs/c group/devices/system.slice/docker-9c813a451e547048906c4da94e382859e0f7ccf0865c79 40b69ff62e21792e3d.scope/cgroup.procs: no such device


(Anoop) #5

Seems like it a known issue with a workaround.
The workaround is to launch the daemon with --exec-opt native.cgroupdriver=cgroupfs to not use systemd as the cgroups.

Workaround detailed here


(Rkharya) #6

Hi,

I am facing the same issue, what ports on the firewall you opened and how?

Thanks,
~ Rajesh.


(Cameronp) #7

Heres the ports I opened:
firewall-cmd --list-ports
2379/tcp 443/tcp 2376/tcp 12379/tcp 12381/tcp 12380/tcp 12382/tcp 2380/tcp 12376/tcp

I also disabled ip 6 and this seemed to allow it to install fine with 0.5 using anoop’s workaround as well.


(Rkharya) #8

Thanks for the list. It helped. Now UCP is up on my setup and i did not disabled ipv6.

Thanks for the help,
~ Rajesh.