Docker Community Forums

Share and learn in the Docker community.

Need HELP: ERROR: Get https://registry-1.docker.io/v2/: x509: certificate signed by unknown authority


(Kmthomps) #1

Has anyone seen this error. I was installing an update and got this error. It’s strange because I originally installed the software 3 months ago and it installed just fine without any errors.

Any ideas on how to resolve it to get this software update installed would be greatly appreciated.


(Maicotimmerman) #2

Have you managed to solve this issue, as I’m currently facing the same issue on Arch linux.


(Stefan Wüthrich) #3

I managed it on my arch server with:
pacman -S ca-certificates
systemctl restart docker


(Kmthomps) #5

I was able to resolve the issue by configuring the proxy setting within Docker. I assumed that Docker utilized the OS proxy settings but it does not. Once I entered in the Docker service proxy setting it worked for me. here are the steps I followed:

  1. First, create a systemd drop-in directory for the docker service:
    mkdir /etc/systemd/system/docker.service.d
    Now create a file called /etc/systemd/system/docker.service.d/http-proxy.conf that adds the HTTP_PROXY environment variable:
    [Service]
    Environment="HTTP_PROXY=http://proxy.example.com:80/"
    Environment="NO_PROXY=localhost,127.0.0.0/8,docker-registry.proxy.example.com"
    export "HTTP_PROXY=http://proxy.example.com:80/"
    export "NO_PROXY=localhost,127.0.0.0/8,docker-registry.proxy.example.com"Flush changes:
  2. Flush Changes

sudo systemctl daemon-reload

  1. Verify that the configuration has been loaded:

sudo systemctl show --property Environment docker

Environment=HTTP_PROXY=http://proxy.example.com:80/
4. Restart Docker:
$ sudo systemctl restart docker


(Tcbabu) #6

I getting same error, I am using it own my private machine, an lfs OS. I am getting the same error. I wish Docker had documented things properly, there are volumes of documents, but very little information. Unfortunate!!!


(Scarlson) #7

The restart did it for me… after you add the cert to your host and do whatever you gotta do to update RESTART DOCKER.