Docker Community Forums

Share and learn in the Docker community.

Need help setting up a Garry's Mod Server

Hi docker forum users!

I recently purchased a Synology DS718+ NAS. So I have been playing around with docker and making some game servers for my friends and I.

So far I have Minecraft and Terraria working perfectly. It was so simple to download an Image and mount it to a folder. I see all the files and could remove worlds etc. as needed.

I then decided to try and make a Garry’s Mod Server since that is what we are currently playing.
First of all it took me a long time to find a Image that worked at all.
Now I have an Image that works: /r/hackebein/garrysmod
The server on it’s own works really well and I can use the parameters to adjust settings like the gamemode etc.

But for some reason the server doesn’t seem to care about changes made to the mount.cfg
I am trying to mount the counter strike source files using the mount.cfg using the path: /docker/garrysmodserver/cstrike

I have also tried many other paths but it just seems like the server won’t even run the mount.cfg.

I know its a very specific thing and most people will not be able to help but maybe someone can help me out.
I hope to make my own Images at some point but I have no clue what I would be doing.

Thank you for your assistance!

Did you ever get this to work?
I am having the exact same issue on my DS918+
I did launch a terminal with steamcmd and got it to download the games to a mounted volume but the mount.cfg and mountdepots.txt are ignored it seems…