Docker Community Forums

Share and learn in the Docker community.

Newbie needing some assistance


(Rdavey228) #1

Hello

Over the last couple weeks I have been getting to grips with docker and decided to teach myself. I’m getting a fairly good grasp of it now and have just ventured out into using docker compose.

I have a docker compose yml file that I found online and have been modfying it to my needs.

Basically this docker compose file runs Sonarr, Radarr, Transmission, openvpn and nginx.

Sonarr and Radarr are using service:vpn as their network so that their traffic passes through the VPN.
NGINX is used as a reverse proxy to get to Sonarr and Radarr at the following urls - http://radarr:7878 & http://sonarr:8989 using “sonarr.myredacteddomain/com” “radarr.myredacteddomain/com” which is working great.

NGINX uses the “Link:” to be able get to sonarr and radarr as you can see from my yml below. Problem i’m now having is that I need Radarr and Sonarr to be able to talk to transmission so that they both know where my download client is located. If on Sonarr I enter transmission:9091 or transmission.myredacteddomain/com Sonarr/Radarr cant see it.

Looking at these containers Radarr and Sonarr dont seem to have an IP address so how is it that NGINX can see them via radarr:7878 etc but Sonarr and Radarr cant see transmission in the same way? Can anyone help me with my yml file here?

version: '3.0'
networks:
  default:
    ipam:
      driver: default
services:
  jackett:
    image: linuxserver/jackett
    depends_on:
      - vpn
    restart: always
    network_mode: "service:vpn"
    environment:
      PGID: 1000
      PUID: 1000
      TZ: Europe/London
    volumes:
      - /mnt/user/config/jackett:/config
      - /mnt/user/media/downloads/jackett:/downloads
      
  transmission:
    image: linuxserver/transmission:48
    depends_on:
      - vpn
    environment:
      TZ: 'Europe/London'
      PGID: 1000
      PUID: 1000
    network_mode: "service:vpn"
    tmpfs:
      - /tmp
    restart: unless-stopped
    stdin_open: true
    tty: true
    volumes:
      - /mnt/user/config/transmission:/config
      - /mnt/user/media/downloads:/downloads

  radarr:
    image: linuxserver/radarr
    depends_on:
      - vpn
    restart: always
    network_mode: "service:vpn"
    environment:
      PGID: 1000
      PUID: 1000
      TZ: Europe/London
    volumes:
      - /mnt/user/config/radarr:/config
      - /mnt/user/media/downloads/complete:/downloads
      - /mnt/user/media/movies:/movies

  sonarr:
    image: linuxserver/sonarr
    depends_on:
      - vpn
    restart: always
    network_mode: "service:vpn"
    environment:
      PGID: 1000
      PUID: 1000
      TZ: Europe/London
    volumes:
      - /mnt/user/config/sonarr:/config
      - /mnt/user/media/downloads/complete:/downloads
      - /mnt/user/media/tvshows:/tv
      
  vpn:
    image: dperson/openvpn-client
    sysctls:
      - net.ipv6.conf.all.disable_ipv6=0
    cap_add:
      - net_admin
    dns:
     - 8.8.4.4
     - 8.8.8.8
    environment:
      TZ: 'Europe/London'
    read_only: true
    tmpfs:
      - /tmp
    restart: unless-stopped
    security_opt:
      - label:disable
    stdin_open: true
    tty: true
    volumes:
      - /dev/net:/dev/net:z
      - /mnt/user/config/vpn:/vpn

  web:
    image: nginx
    depends_on:
      - transmission
      - sonarr
      - jackett
      - radarr
    environment:
      TZ: 'Europe/London'
      IPV6: 0
    links:
      - vpn:transmission
      - vpn:jackett
      - vpn:radarr
      - vpn:sonarr
    ports:
      - "80:80"
      - "443:443"
    read_only: true
    volumes:
      - /mnt/user/config/nginx:/etc/nginx/conf.d:ro
      - /mnt/user/config/nginx/ssl:/etc/nginx/ssl:ro
    tmpfs:
      - /run
      - /tmp
      - /var/cache/nginx
    restart: unless-stopped
    stdin_open: true
    tty: true