Docker Community Forums

Share and learn in the Docker community.

No activity detected on VM, aborting

#1

Hi,
I have recently downloaded and installed docker for windows.

If I run windows containers, it runs fine. If I try to install on linux containers (or swap from windows to linux) it just fails and I get the following error:

No activity detected on VM, aborting
at Docker.Core.Pipe.NamedPipeClient.Send(String action, Object parameters) in C:\workspaces\stable-18.09.x\src\github .com\docker\pinata\win\src\Docker.Core\pipe\NamedPipeClient.cs:line 36
at Docker.Actions.<>c__DisplayClass28_0.b__0() in C:\workspaces\stable-18.09.x\src\github .com\docker\pinata\win\src\Docker.Windows\Actions.cs:line 305
at Docker.WPF.TaskQueue.<>c__DisplayClass19_0.<.ctor>b__1() in C:\workspaces\stable-18.09.x\src\github .com\docker\pinata\win\src\Docker.WPF\TaskQueue.cs:line 59

I am runnning 18.09.1

I have seen some older posts, but they refer to earlier versions or use toolbox.
I have tried to reinstall, clear everything I can, create a public virtual switch on hyper-V, reset the file sharing on the adapter, and anything else that people could suggest, but it makes no difference.

I can’t even get started with docker.

Can anyone shed any light? Or maybe I am just fighting an unwinnable battle here and I should just embrace windows containers, if there isn’t really a difference between the two options?

Thanks

#2

I have been struggling with this for a week and finally found a solution in github - see if it helps:


( as per zulli73 on 29 Dec 2018 )

Basically. this is what I did:

  1. I used Task Manager to kill the infinite-running Docker Desktop that was stuck attempting to start
  2. I went into Hyper-V Manager, stopped the MobyLinuxVM and set the number of processors to 1 ( down from 2 ) , max processors to 1 ( down from 4 ) - incidentally I also reduced the max RAM from 8GB to 4GB, but that wouldn’t have been the cause of the issue.
  3. then I could finally start Docker Desktop.

Platform: Windows 10 LSB ( 10.0.14393 ) physical box.
Docker version 18.09.2, build 6247962

PS U:> docker version
Client: Docker Engine - Community
Version: 18.09.2
API version: 1.39
Go version: go1.10.8
Git commit: 6247962
Built: Sun Feb 10 04:12:31 2019
OS/Arch: windows/amd64
Experimental: false

Server: Docker Engine - Community
Engine:
Version: 18.09.2
API version: 1.39 (minimum version 1.12)
Go version: go1.10.6
Git commit: 6247962
Built: Sun Feb 10 04:13:06 2019
OS/Arch: linux/amd64
Experimental: false

It is disconcerting seeing that so many folks have been reporting this issue for months and this potential work-around doesn’t seem to have been acknowledged, patched, or suggested formally in the troubleshooting advice - at least I haven’t come across it in my digging for answers.


See below the list of issues dealing with this issue, that I came across in github:

No activity detected on VM, aborting when switching to Linux containers #2971

Latest Docker version not working or starting on windows 10 Professional #2945

No activity detected on VM, aborting #2924

Can’t launch Docker in Win10 #2887

No activity detected on VM, aborting #2881

No activity detected on VM, aborting #2872

No activity detected on VM, aborting #2728

what’s error windows10 #2712

No activity detected on VM, aborting #2316

No activity detected on VM, aborting #2253


#3

unfortunately it did not work for me.

I have tried going back to 3 different versions, changing processors to 1, including virtual processors. reducing memory, unplugging myself from wired and wireless connections independently and unplugging myself completely off the network.

All to no avail.

At this pace, I don’t think we’ll be getting very far with docker.
My colleagues are on Windows 7, so that puts an even bigger spanner in the works for them. But if I can’t even make it work on W10, what’s the point?

#4

In case it may help. It seems to have finally started.
I started docker until it failed completely. Then I opened settings on docker desktop and changed to 1 processor.
My hyper-v machine is set to 1 processor too. The NUMA settings are to a maximum of 1 processor, maximum memory reduced from 6+GB to 2.5GB.
Processor compatibility is ticked on the “migrate to a physical computer…”
The only other conscious change I made, was to change the vEthernet from public to private via the following powershell command:
Set-NetConnectionProfile -interfacealias “vEthernet (DockerNAT)” -NetworkCategory Private

I will try restarting, this may work.