Docker Community Forums

Share and learn in the Docker community.

No such file when starting container

I have a container that I have built and started on many different machines, both linux and mac, but always on bare metal. I am now trying to run it on an instance in the cloud at linode. When I try and start the container it fails with:

/usr/bin/docker-current: Error response from daemon: oci runtime error: container_linux.go:235: starting container process caused “exec: “/opt/capcompute/”: stat /opt/capcompute/ no such file or directory”.

The file exists and is world readable and executable. I have tried commenting out everything in the file and I still get the error. I can run other containers on this same machine. What could the issue be, and how can I debug it?

Running with the following docker-compose.yml:

image: node:12-alpine
- ./app:/srv/app
working_dir: /srv/app
command: “npm start”
npm fails to run with “Error: ENOENT: no such file or directory, uv_cwd”. I can manage to start the container via the dashboard, but opening the cli for it prints:

sh: getcwd: No such file or directory
(unknown) #
I can browse and view the files though. I have a feeling this is linked to the container not starting first time around…

Windows Version: 10
Docker Desktop Version:
Are you running inside a virtualized Windows e.g. on a cloud server or on a mac VM: No

I resolved this - it was a volume mounting issue.

This is take from:
It realy looks like lewish95 is just a simple bot that takes the first response from google…