Orphan repository after deleted organization

After deleting an organization with a repository and image pushed the organization name is locked (As it is still referenced by the repo image) and the image is orphan.

How can I delete the orphan repository to recover the organization name?



Unfortunately, based on the documentation, there doesn’t seem to be any real way, as this shouldn’t have happened. The connected repositories should have been removed with the removal of the organization according to the documentation. I literally tried making an organization called “testplace,” and then immediately deleted it, and the end result is that I can no longer make an organization called “testplace.” This is actually looking like this is a bug. Not something you did wrong.


Thanks a lot for your reponse, but I can create as many orphan repos as I want.

Try the following flow:

1.- Create a new organization
2.- Create a new public repository in that newly created organization
3.- Deactivate the organization

As a result:

1.- The organization is gone, but your repo still alive.
2.- The organization name is locked forever and the repo is orphan, you cannot delete, modify that repo.

You can see an example here:


This can be a security issue as I can potentially civil attach dockerhub and drain their resources.

Is there anyway of raising further?

Thanks for your help.


Indeed. I also tried this as well, and you’re right, this can definitely be replicated. I’m not sure where to report this, but this should definitely be a bug. I suppose going to github might be where you need to report it.

Try one of these project links and report it there.