Docker Community Forums

Share and learn in the Docker community.

Permission denied @ rb_sysopen - /root/.env.local (errno::eacces)

I want to use one service that is not yet public. The service documentation asked to create an image of it by running a script which while executing asked for the Docker creds to create the image. The image was created successfully. Then in the final step to be able to access its commands through CLI, it requires one .sh script file to be run. I tried using just bash filename.sh in command prompt, but immediately exits the container. So when I run the image using Dev Env in Docker Desktop for Windows app it should execute the image’s instance that is a container and allow me to run the CLI of the service in there. But instead, it gives me ‘permission denied @ rb_sysopen - /root/.env.local (errno::eacces)’. Here ‘.env/.local’ is the file containing the creds required by the container to be able to run.

Since we don’t now what service and app you are using, it can be anything. What this filename.sh does? Is it a something that is running in a loop? If it is not and just lists files in the home folder, it is the expected behavior.