Docker Community Forums

Share and learn in the Docker community.

PicApport docker error


#1

Hi folks,

as I am new to this forum, I don’t know, if I am right here…
I tried to use the docker image “PicApport” created from fionnb on my Ubuntu server, but I get some errors after running.
My steps are following:

I created the needed folders:
/home/docker/PicApport/data
/home/docker/PicApport/Pictures

and gave all users the rights to r/w (just for testing purposes)

then I invoked:
docker run -d -p 9090:8888 -v /home/docker/PicApport/Pictures:/opt/picapport/photos -v /home/docker/PicApport/data:/opt/picapport/data --name picapport fionnb/picapport:stable; docker logs -f picapport

It gave some log information at the console:

> Unable to find image 'fionnb/picapport:stable' locally
> stable: Pulling from fionnb/picapport
> 0865c4eef802: Pull complete
> a3ed95caeb02: Pull complete
> 403d366906eb: Pull complete
> 8dc7e10f01e3: Pull complete
> 44aa4719ebfb: Pull complete
> Digest: sha256:4550557afb45b8fc9d25802deb15d51dd114220626e35a83b2ca67807559a0c0
> Status: Downloaded newer image for fionnb/picapport:stable
> 18891b69f5df9539f84dee35d5bf92e6faa9ba7e6408fdeb8ac2996bc1925012
> find: ‘data/picapport.ks’: No such file or directory
> PicApport headless set default option -Dmemory.useUnsafe=false
> Logging to file: /opt/picapport/data/logfiles/picapport.000
> Copyright (c) 1997-2019 Contecon Software GmbH. All rights reserved.
> 2019-01-22 15:42:23
> Tracelevel: ERROR
> VER  @ 15:42:23.636 PicApport Version 7.2 from 18.05.2018 loaded.
> VER  @ 15:42:23.637 de.contecon.picapport.PicApport.Version=V7.2.0 18.05.2018
> VER  @ 15:42:23.638 java.runtime.version: 1.8.0_171-8u171-b11-0ubuntu0.16.04.1-b11
> VER  @ 15:42:23.638 java.version: 1.8.0_171
> VER  @ 15:42:23.638 java.vm.version: 25.171-b11
> VER  @ 15:42:23.638 java.vm.vendor: Oracle Corporation
> VER  @ 15:42:23.639 java.vm.name: OpenJDK 64-Bit Server VM
> VER  @ 15:42:23.639 java.specification.version: 1.8
> VER  @ 15:42:23.639 java.vm.specification.version: 1.8
> VER  @ 15:42:23.639 os.name: Linux
> VER  @ 15:42:23.640 os.version: 4.15.0-43-generic
> VER  @ 15:42:23.640 os.arch: amd64
> MSG  @ 15:42:23.640 java.runtime totalMemory=48mb maxMemory=699mb freeMemory=44mb processors=2
> MSG  @ 15:42:23.644 java.runtime.argument: -Duser.home=/opt/picapport
> MSG  @ 15:42:23.645 java.runtime.argument: -Duser.language=$PICAPPORT_LANG
> MSG  @ 15:42:23.645 java.runtime.argument: -Dpicapport.directory=data
> MSG  @ 15:42:23.645 java.runtime.argument: -XX:MaxDirectMemorySize=3954m
> MSG  @ 15:42:23.645 PicApport home=/opt/picapport/data
> MSG  @ 15:42:23.646 PicApport logging to /opt/picapport/data/logfiles
> MSG  @ 15:42:23.646 Loading config File: /opt/picapport/data/picapport.properties
> MSG  @ 15:42:24.349 PicApportProperties.client.video.types.json[0].ext=.mp4 mime=video/mp4
> MSG  @ 15:42:24.350 PicApportProperties.client.video.types.json[1].ext=.ogv mime=video/ogg
> MSG  @ 15:42:24.350 PicApportProperties.client.video.types.json[2].ext=.webm mime=video/webm
> MSG  @ 15:42:24.353 Init: picApportHome=/opt/picapport/data
> MSG  @ 15:42:24.355 Init: server.port=80
> MSG  @ 15:42:24.356 Init: server.ssl=false
> MSG  @ 15:42:24.360 Init: foto.jpg.usecache=2
> MSG  @ 15:42:24.360 Init: gui.enabled=false
> MSG  @ 15:42:24.361 Init: gui.hideintray=true
> MSG  @ 15:42:24.361 Init: robot.root.0.id=id0
> MSG  @ 15:42:24.361 Init: robot.root.0.path=/opt/picapport/photos
> MSG  @ 15:42:24.362 Init: robot.root.0.isuploadroot=true
> MSG  @ 15:42:24.362 Init: server.demomode=false
> MSG  @ 15:42:24.431 Initialize user database in /opt/picapport/data/users
> MSG  @ 15:42:24.435 Load users from /opt/picapport/data/users
> MSG  @ 15:42:24.477 Initializing User Management: CcUser2  V1.5 build:2017.10.09-##CC_BUILD##
> MSG  @ 15:42:25.161 User Management: Initializing/creating UniqueId store in: /opt/picapport/data/users/vars/id_counter
> MSG  @ 15:42:25.297 Init user management: Create default group: System administration
> MSG  @ 15:42:25.358 Init user management: Create default group: Family
> MSG  @ 15:42:25.362 Init user management: Create default group: Guests
> MSG  @ 15:42:25.366 Init user management: Create user: System administrator for group admins
> MSG  @ 15:42:25.428 Init user management: Create user: PicApport for group family
> MSG  @ 15:42:25.455 Init user management: Create user: Guest for group guests
> MSG  @ 15:42:25.481 User Management: DB-Version updated to: 7.02
> MSG  @ 15:42:25.490 Search for plugins in /opt/picapport/data/plugins
> MSG  @ 15:42:25.495 Queries loaded: 0
> MSG  @ 15:42:25.499 Designs loaded: 0 from /opt/picapport/data/designs
> MSG  @ 15:42:25.522 PicApportDBService.createDatabaseDirectory: /opt/picapport/data/db
> MSG  @ 15:42:25.523 PicApportDBService.startDatabase:plocal:/opt/picapport/data/db/db.2.2.26
> Jan 22, 2019 3:42:26 PM com.orientechnologies.common.log.OLogManager log
> INFO: OrientDB auto-config DISKCACHE=282MB (heap=667MB direct=3,954MB os=2,997MB)
> 2019-01-22 15:42:48.504:INFO::main: Logging initialized @25316ms to org.eclipse.jetty.util.log.StdErrLog
> 2019-01-22 15:42:48.601:WARN:oejsh.ContextHandler:main: Empty contextPath
> 2019-01-22 15:42:48.635:INFO:oejs.Server:main: jetty-9.4.z-SNAPSHOT, build timestamp: 2017-11-21T21:27:37Z, git hash: 82b8fb23f757335bb3329d540ce37a2a2615f0a8
> 2019-01-22 15:42:48.695:INFO:oejs.session:main: DefaultSessionIdManager workerName=node0
> 2019-01-22 15:42:48.695:INFO:oejs.session:main: No SessionScavenger set, using defaults
> 2019-01-22 15:42:48.697:INFO:oejs.session:main: Scavenging every 660000ms
> 2019-01-22 15:42:48.708:INFO:oejsh.ContextHandler:main: Started o.e.j.s.ServletContextHandler@420bc288{/,null,AVAILABLE}
> ERROR@ 15:42:48.719 Exception Error (re)start server:: java.net.SocketException: Permission denied
> MSG  @ 15:43:16.688 7 thumbs loaded.

therefor, it isn’t reachable from the Web-interface maybe due to the “Exception Error (re)start server:: java.net.SocketException: Permission denied” error.

I don’t know, what I missed…

Can someone help me out with this?

Best regards,
Peuqui


#2

Hi Peuqui,

i have the same issue. Did you solve this problem?

Regards
Ben


(Gary Forghetti) #3

I just tried it myself. Got the same socket error.
It was trying to open Port 80 instead of 8888.
So was your container.
> MSG @ 15:42:24.355 Init: server.port=80

I did get it working. Here’s how.

Had to create an ENV file in the data directory according to the documentation on that image in docker hub > https://hub.docker.com/r/fionnb/picapport/

🐳 gforghetti:[~/Downloads] $ mkdir data
🐳 gforghetti:[~/Downloads] $ mkdir photos
🐳 gforghetti:[~/Downloads] $ echo -e "PICAPPORT_PORT=8888\nPICAPPORT_LANG=\"en\"" > data/ENV
🐳 gforghetti:[~/Downloads] $ cat data/ENV
PICAPPORT_PORT=8888
PICAPPORT_LANG="en"
🐳 gforghetti:[~/Downloads] $ docker run -d -p 8080:8888 -v $(pwd):/opt/picapport/photos -v $(pwd)/data:/opt/picapport/data --name picapport fionnb/picapport
48d3029a89ecc5f682566aa46804fb3ce19c82a5109d18ce588add3ab731b13f