Docker Community Forums

Share and learn in the Docker community.

Place URL for jenkins agent in docker-compose

Hi,

I am using docker-compose for install Squash-TF execution with Jenkins.
One of container is for Jenkins server then the second container is for agent which try to connect at the server.
But when I launch the agent, I have the following error :

Blockquote :
Warning: JnlpProtocol3 is disabled by default, use JNLP_PROTOCOL_OPTS to alter the behavior
Squash-TF-agent | At least one -url option is required.
Squash-TF-agent | java -jar agent.jar [options…]
Squash-TF-agent | -agentLog FILE : Local agent error log destination (overrides
Squash-TF-agent | workDir)
Squash-TF-agent | -cert VAL : Specify additional X.509 encoded PEM
Squash-TF-agent | certificates to trust when connecting to
Squash-TF-agent | Jenkins root URLs. If starting with @ then
Squash-TF-agent | the remainder is assumed to be the name of
Squash-TF-agent | the certificate file to read.
Squash-TF-agent | -credentials USER:PASSWORD : HTTP BASIC AUTH header to pass in for making
Squash-TF-agent | HTTP requests.
Squash-TF-agent | -disableHttpsCertValidation : Ignore SSL validation errors - use as a last
Squash-TF-agent | resort only. (default: false)
Squash-TF-agent | -failIfWorkDirIsMissing : Fails the initialization if the requested
Squash-TF-agent | workDir or internalDir are missing (‘false’
Squash-TF-agent | by default) (default: false)
Squash-TF-agent | -headless : Run in headless mode, without GUI (default:
Squash-TF-agent | false)
Squash-TF-agent | -internalDir VAL : Specifies a name of the internal files
Squash-TF-agent | within a working directory (‘remoting’ by
Squash-TF-agent | default) (default: remoting)
Squash-TF-agent | -jar-cache DIR : Cache directory that stores jar files sent
Squash-TF-agent | from the master
Squash-TF-agent | -loggingConfig FILE : Path to the property file with
Squash-TF-agent | java.util.logging settings
Squash-TF-agent | -noKeepAlive : Disable TCP socket keep alive on connection
Squash-TF-agent | to the master. (default: false)
Squash-TF-agent | -noreconnect : If the connection ends, don’t retry and just
Squash-TF-agent | exit. (default: false)
Squash-TF-agent | -proxyCredentials USER:PASSWORD : HTTP BASIC AUTH header to pass in for making
Squash-TF-agent | HTTP authenticated proxy requests.
Squash-TF-agent | -tunnel HOST:PORT : Connect to the specified host and port,
Squash-TF-agent | instead of connecting directly to Jenkins.
Squash-TF-agent | Useful when connection to Jenkins needs to
Squash-TF-agent | be tunneled. Can be also HOST: or :PORT, in
Squash-TF-agent | which case the missing portion will be
Squash-TF-agent | auto-configured like the default behavior
Squash-TF-agent | -url URL : Specify the Jenkins root URLs to connect to.
Squash-TF-agent | -workDir FILE : Declares the working directory of the
Squash-TF-agent | remoting instance (stores cache and logs by
Squash-TF-agent | default)
Squash-TF-agent exited with code 0

So I try different way for give URL like environment variable but I found any solution.
I am using the following docker-compose.yml :

Blockquote :
version: ‘3.7’
services:
squash-tf-server:
container_name: Squash-TF-server
ports:
- 8020:8080/tcp
image: squashtest/squash-tf-execution-server:2.3.0-RELEASE
volumes:
- “/var/lib/squash-tf-server-execution:/var/lib/squash-tf-server-execution/data”
squash-tf-agent:
container_name: Squash-TF-agent
depends_on:
- squash-tf-server
environment:
squash-tf-agent_URL: “tcp://localhost:8020/jenkins/”
JENKINS_AGENT_NAME: agent_name
JENKINS_SECRET: ****
ports:
- target: 8010
published: 8010
protocol: tcp
mode: ingress
image: squashtest/squash-tf-firefox-ui-execution-agent
links:
- squash-tf-server:server

squash-tf-server server is running successful. Jenkins and Jenkins-node are configured

Someone can tell me where is my mistake?