Docker Community Forums

Share and learn in the Docker community.

Port mappings are not released

docker
beta

(Davidg707) #62

Getting the same thing here, Error starting userland proxy: Bind for 0.0.0.0:3306 failed: port is already allocated after restarting macOS for an update while it was running.

I just did a ‘Factory reset’ and the problem persists. How can that be?

I’m new to docker, I don’t know what rm -f /var/lib/docker/network/files/local-kv.db means. Where do I type that? docker-machine ssh tells me Error: No machine name(s) specified and no "default" machine exists. I don’t know what machine name I should be using (I’m running someone else’s scripts, I don’t know what they do). I do docker-machine ls and there is nothing in the list.

Docker version 17.12.0-ce, build c97c6d6

Any help for dummies would be great, thanks!


(Manmedia) #63

What are you trying to run? Hello world?


(Davidg707) #64

No I’ve just started a new job so I’m following their install instructions for some wildly complicated setup. Do you know what a factory reset leaves behind?


(Manmedia) #65

Shouldn’t leave behind anything. Did you check this?


(Davidg707) #66

Yes, I tried docker rm -v mydbcontainer then started everything again and get the same error still.