Docker Community Forums

Share and learn in the Docker community.

Preferred Docker CLI/Engine version to push/pull images to/from Docker Trusted Registry


(Ricardo Quintana) #1

Hello,

My team has been evaluating DTR (v 1.3.1) to integrate it into our CI / CD pipeline and we ran into an issue where there was unreliable push / pull functionality to the DTR. We were getting 404 Not Found errors. We noticed that we had to docker logout / login and sometimes that would fix the issue, but it was not consistent anyways. We ran the docker engine in debug mode and found out that in the handshake with the DTR, docker was defaulting to the v1 registry protocol and then it was failing. We were using 1.8.1. We then tried to use the commercial version of the docker engine (1.6.2-cs5) and this has solved our inconsistency issues pushing / pulling images to the the DTR.

My question is then: is the docker commercial version the only version that is supported to be used as a client to the DTR?

Thanks in advance!


(Ralph Kincade) #2

yes docker-CS is the only version that officially is supported and only on RHEL and Ubuntu


(Ricardo Quintana) #3

OK, sounds good. I was under the impression that it was for running the DTR containers, but it is not very clear that it is also to interact with the DTR as a client. Perhaps that would be a good addition to the docs :smile:

Thanks!


(Ralph Kincade) #4

yeah it is funny , you posted this question exactly when we discussed this in class , here is the slide on this
nstallation requirements

DTR license

Commercially supported version of Docker Engine (CS Engine)

CS Engine only supported on RHEL v7.0, 7.1 or Ubuntu 14.04 LTS

Download the RPM or DEB package from your Enterprise License page in Docker Hub and then copy it into your host machine

Full installation instructions at

https://docs.docker.com/docker-hub-enterprise/install/


(Ricardo Quintana) #5

@brikeyes Thanks again. What class are you teaching?


(Ralph Kincade) #6

https://training.docker.com/class/docker-training/docker-administration-and-operations/raleigh-north-carolina/2015-09-22 https://training.docker.com/class/docker-training/docker-administration-and-operations/raleigh-north-carolina/2015-09-22

we are doing another one in NYC in OCT.


(Eric5102) #7

btw, this means the DTR sold in the AWS marketplace is not fully supported in AWS? AWS services do not use the CS version so using the DTR with them is not supported?!? I find that hard to believe.

AWS services that use docker but do not allow installing the CS version include AWS Elastic Beanstalk, AWS Opsworks and AWS EC2 Container Service. Possibly others I am not aware of. When an auto-scaling group adds instances the version of docker allowed by AWS is installed automatically and you don’t have any control on this.

eric